summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/aranym
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/aranym')
-rw-r--r--app-emulation/aranym/Manifest3
-rw-r--r--app-emulation/aranym/aranym-0.9.14.ebuild59
-rw-r--r--app-emulation/aranym/aranym-0.9.16.ebuild59
-rw-r--r--app-emulation/aranym/metadata.xml24
4 files changed, 145 insertions, 0 deletions
diff --git a/app-emulation/aranym/Manifest b/app-emulation/aranym/Manifest
new file mode 100644
index 000000000000..7751ff866a79
--- /dev/null
+++ b/app-emulation/aranym/Manifest
@@ -0,0 +1,3 @@
+DIST afros812.zip 9087862 SHA256 7d60230694734a42d912f47d03653f60ffd5a034d89771df35a414b6a6af6263 SHA512 0e9522740dc38c34b1fab4a999485caca0af95692d281bf2887fe6dddf48cceaf6c4d8b9802f402e2bd00726fb01c557ffb5731838ebd94b9eec987f1f0ce545 WHIRLPOOL bc641fef78cff4fb14448b0054eb39505a507d73f1511fb0d801f06637e0c81e2311c6c1fe1391aea379f967d5f20032e4ffb5184d9a9f39f3530c3cfeb63550
+DIST aranym_0.9.14.orig.tar.gz 1831715 SHA256 04e85337fbf54cb3c80c2d26ce22f51337abc2ddc730d9bf9ed3b171def4b9fa SHA512 8145546bf6f6ffea8f4ea24f0fbfc19d1b33146b30473757dcf04c7603125f7f3a36f266ad190baf310510fa50b5f9ecfe2cd8627dea292d3851e6c64cf4fc17 WHIRLPOOL 86ad78d2a7ff0c66f94875bfb6d80957436bf594bd201884d8fee3e541aa11f5d03d16500807b3d9172155c5284e94d4d251913f08869def4d4bfd33f1d24bc7
+DIST aranym_0.9.16.orig.tar.gz 1778730 SHA256 11e7ca0dd93d42966c2ec70749a3c1e4345656ad1108a126ecd9754391a308c6 SHA512 b2848b1c6726b0e85f76da144a3f4f478bed13a1bc528658a448499c5e3434d5adb2ff6e0625d814a6e15a6d1ca9fe8922a3f282b50b1cb7763bb09c64342ae8 WHIRLPOOL 48a5cf68c4243c18292e3948d688ee8dc29306986b05177cc469cd6915dabe8733994f1578272acfac939cbae77d27a3bb4ced8fa41aa70cfb70ce503b6c717d
diff --git a/app-emulation/aranym/aranym-0.9.14.ebuild b/app-emulation/aranym/aranym-0.9.14.ebuild
new file mode 100644
index 000000000000..dfb397f37bb3
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.14.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Atari Running on Any Machine, a VM running Atari ST/TT/Falcon OS and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${P/-/_}.orig.tar.gz
+ mirror://sourceforge/aranym/afros812.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="+fullmmu +lilo opengl usbhost X"
+
+RDEPEND="games-emulation/emutos
+ media-libs/libsdl
+ opengl? ( virtual/opengl )
+ X? ( media-libs/libsdl[X] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ filter-flags -mpowerpc-gfxopt
+
+ local myconf=""
+ if [[ ${ARCH} == x86 ]]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ if ! use X; then
+ myconf="${myconf} --disable-nfjpeg --disable-nfclipbrd"
+ fi
+
+ econf \
+ $(use_enable X gui) \
+ $(use_enable opengl) \
+ $(use_enable fullmmu) \
+ $(use_enable lilo) \
+ $(use_enable usbhost) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install
+
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/afros
+
+ dodoc "${D}"/usr/share/doc/${PN}/*
+ rm -r "${D}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}
diff --git a/app-emulation/aranym/aranym-0.9.16.ebuild b/app-emulation/aranym/aranym-0.9.16.ebuild
new file mode 100644
index 000000000000..42dc1347a456
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Atari Running on Any Machine, a VM running Atari ST/TT/Falcon OS and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${P/-/_}.orig.tar.gz
+ mirror://sourceforge/aranym/afros812.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+fullmmu +lilo opengl usbhost X"
+
+RDEPEND="games-emulation/emutos
+ media-libs/libsdl
+ opengl? ( virtual/opengl )
+ X? ( media-libs/libsdl[X] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ filter-flags -mpowerpc-gfxopt
+
+ local myconf=""
+ if [[ ${ARCH} == x86 ]]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ if ! use X; then
+ myconf="${myconf} --disable-nfjpeg --disable-nfclipbrd"
+ fi
+
+ econf \
+ $(use_enable X gui) \
+ $(use_enable opengl) \
+ $(use_enable fullmmu) \
+ $(use_enable lilo) \
+ $(use_enable usbhost) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install
+
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/afros
+
+ dodoc "${D}"/usr/share/doc/${PN}/*
+ rm -r "${D}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}
diff --git a/app-emulation/aranym/metadata.xml b/app-emulation/aranym/metadata.xml
new file mode 100644
index 000000000000..d60a27928e66
--- /dev/null
+++ b/app-emulation/aranym/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ ARAnyM is an acronym: Atari Running on Any Machine. It is a virtual
+ machine software for running the Atari ST/TT/Falcon operating systems
+ (TOS, FreeMiNT, MagiC and others) and TOS/GEM applications. In the
+ combination of ARAnyM/Linux and AFROS you basically get a completely
+ free TOS/MiNT compatible operating system running on any machine.
+ That's a break-through for all Atari users - now you can turn almost
+ any hardware into your familiar TOS/GEM system.
+ </longdescription>
+ <use>
+ <flag name="fullmmu">Enable full 68040 MMU emulation</flag>
+ <flag name="lilo">Enable Linux-m68k loader</flag>
+ <flag name="usbhost">Enable NatFeat USB</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">aranym</remote-id>
+ </upstream>
+</pkgmetadata>