summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Günzler <r@gnzler.io>2020-06-02 13:51:49 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-02 14:13:43 +0300
commit087d5a760fc580a7ca678f8698f31cf2172b2438 (patch)
tree0ed3a50a8e13eb2a75dc44dd06d5de18980f9b29 /app-emulation/crun
parentapp-emulation/crun: Bump to 0.13 (diff)
downloadgentoo-087d5a760fc580a7ca678f8698f31cf2172b2438.tar.gz
gentoo-087d5a760fc580a7ca678f8698f31cf2172b2438.tar.bz2
gentoo-087d5a760fc580a7ca678f8698f31cf2172b2438.zip
app-emulation/crun: Remove 0.10.6
Signed-off-by: Robert Günzler <r@gnzler.io> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation/crun')
-rw-r--r--app-emulation/crun/Manifest1
-rw-r--r--app-emulation/crun/crun-0.10.6.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index 56e3366c82be..24ebd99e11ba 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1,2 +1 @@
DIST crun-0.13.tar.gz 1305048 BLAKE2B fbffabf4cfc744522147b47c5e2bf2bc48e074866108ec4ec8ab94e7ebdc39451851696fabde268b5853e1c3fafb0ac93527e08fdb766acebdd7cf952a9e1a9e SHA512 314612eaf3097160e9369b3400ac8a83e173ef1a53295191c925e96212ba00d032883db1e4615b8ba42ddb08f1e31ca5e5088ea583a469835ac3c27087a88d6e
-DIST crun-0.10.6.tar.gz 1242736 BLAKE2B 840699c6a07ddaef3f6ab4ce226fa6c4ebf0e32641012b6467a2a622d575a48286555b84140d5a1c947b5ef00a691045b0618533fb246bfb6d605baa262febe4 SHA512 b7db09d0c7d2d6e8b1ea239ead5a2ca2b97f188a74f08f0d5ac787e0a698fddf596e7cfdde482c6bc8790d06a7705613e877344a44691c0be7388e6d046c4b15
diff --git a/app-emulation/crun/crun-0.10.6.ebuild b/app-emulation/crun/crun-0.10.6.ebuild
deleted file mode 100644
index a644095e871b..000000000000
--- a/app-emulation/crun/crun-0.10.6.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="bpf +caps doc seccomp systemd static-libs"
-
-DEPEND="
- dev-libs/yajl
- sys-libs/libseccomp
- caps? ( sys-libs/libcap )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- doc? ( dev-go/go-md2man )
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the priveledges
-# required to create linux "containers."
-RESTRICT="test"
-
-DOCS=README.md
-
-src_configure() {
- econf \
- $(use_enable bpf) \
- $(use_enable caps) \
- $(use_enable seccomp) \
- $(use_enable systemd) \
- $(usex static-libs '--enabled-shared --enabled-static' '--enable-shared --disable-static' '' '')
-}
-
-src_compile() {
- pushd libocispec || die
- emake
- popd || die
- emake crun
- if use doc ; then
- emake crun.1
- fi
-}
-
-src_install() {
- pushd libocispec || die
- emake "DESTDIR=${D}" install-exec
- popd || die
- emake "DESTDIR=${D}" install-exec
- if use doc ; then
- emake "DESTDIR=${D}" install-man
- fi
-
- # there is currently a bug in upstream autotooling that continues to build static libraries despite
- # explicit configure options
- use static-libs || find "${ED}"/usr -name '*.la' -delete
-
- einstalldocs
-}