summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Günzler <r@gnzler.io>2020-11-27 11:09:48 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-20 16:13:42 +0200
commita58b9ec95c97885957089cf3c50260967ab5f1f1 (patch)
tree51b4ea3187f2cd81488aa0a967d9d7f171871d5d /app-emulation/crun
parentapp-emulation/crun: bump to 0.16 (diff)
downloadgentoo-a58b9ec95c97885957089cf3c50260967ab5f1f1.tar.gz
gentoo-a58b9ec95c97885957089cf3c50260967ab5f1f1.tar.bz2
gentoo-a58b9ec95c97885957089cf3c50260967ab5f1f1.zip
app-emulation/crun: Drop 0.14.1
Signed-off-by: Robert Günzler <r@gnzler.io> Closes: https://github.com/gentoo/gentoo/pull/18415 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation/crun')
-rw-r--r--app-emulation/crun/Manifest2
-rw-r--r--app-emulation/crun/crun-0.14.1.ebuild79
2 files changed, 0 insertions, 81 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index 58b2d2f32ab3..c4fedb0663f3 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1,4 +1,2 @@
-DIST crun-0.14.1.tar.gz 1341891 BLAKE2B c20d5001161e298050ddca859fa78487fe3f8577ef0b06eb5515056f19ba4f981debeb684148de49111a0370b9bafb7f6454d65f7ecf087862c697a162c9b377 SHA512 420f1713653cbd17df83b2a63d163aaa41baf78115b093877a2241305e10b2ceeaf08ea6700658eca894729ff8a20cbc66f868d18d27fba3fbedf1a9993b122e
DIST crun-0.15.tar.gz 1364861 BLAKE2B 7078e71229bae4bc663398891b21344abc3189c78a11e4feeae3236e1df4a2c5160cf26f2cc243d4c0898a642a779603d473d2c22ca2b67123c6ac4654fce4d7 SHA512 f9a9e94b6a9c5cff01fe93b1c3d5876a0794e6288b802cf579556e11411ca5d6e63cae3859aaa4df4bb600e2d27aa131872a93a92784b9b48f7885411d86f325
DIST crun-0.16.tar.gz 1370194 BLAKE2B c2a2450518226421b43d93597b38da80ca330cb3d8d9c259f323d49561e93dc3d003a25599eb8e918888dd824037c53bd0a07624c3154fa3778cc6dad37ac04b SHA512 f5a0d19c037af55478ee5f83b63d74277c8640f715b81a8233d3f1acd4cdfdad491e5c1f5beda04d0d7aa16693e9a004b0bde71343b082aa514ae76e5907d029
-DIST libcrun.lds 257 BLAKE2B 00e7cdf3162ea0b7231dbb9037b192bcf5ffa83316e1aa60268560bc9fe8302be351c405861f9dfc06620ea64561a9226f58b7133039c0af1299dc4088b98272 SHA512 0e9b836c79ee4ad7ff33c592eca8ff41f38aed588f2f5a2416bed82efa819cd4c61ad65a2dfd11a37838a19d950688b1d5adb3b75841963dbb589536e8a867f7
diff --git a/app-emulation/crun/crun-0.14.1.ebuild b/app-emulation/crun/crun-0.14.1.ebuild
deleted file mode 100644
index 651d5f88be89..000000000000
--- a/app-emulation/crun/crun-0.14.1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit autotools python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz
- https://github.com/containers/${PN}/raw/${PV}/libcrun.lds"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
-IUSE="bpf +caps man seccomp systemd static-libs"
-
-DEPEND="
- dev-libs/yajl
- caps? ( sys-libs/libcap )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- man? ( dev-go/go-md2man )
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-DOCS=( README.md )
-
-src_unpack() {
- # dont' try to unpack the .lds file
- MY_A=( ${A[@]/libcrun.lds} )
- unpack ${MY_A}
-}
-
-src_prepare() {
- default
- eautoreconf
- cp -v "${DISTDIR}"/libcrun.lds "${S}"/ || die "libcrun.lds could not be copied"
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-criu \
- $(use_enable bpf) \
- $(use_enable caps) \
- $(use_enable seccomp) \
- $(use_enable systemd) \
- $(usex static-libs '--enabled-shared --enabled-static' '--enable-shared --disable-static' '' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C libocispec
- emake crun
- if use man ; then
- emake generate-man
- fi
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- if use man ; then
- emake "DESTDIR=${D}" install-man
- fi
-
- einstalldocs
-}