summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-30 09:55:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-30 09:56:59 -0500
commita137f4733ab32516a59f1826a6d491630b1db363 (patch)
tree4cacf86cdd403ad5acd46b9c331f8d5bdef7c858 /app-emulation/diskimage-builder/diskimage-builder-2.29.1.ebuild
parentapp-admin/helm: Remove old (diff)
downloadgentoo-a137f4733ab32516a59f1826a6d491630b1db363.tar.gz
gentoo-a137f4733ab32516a59f1826a6d491630b1db363.tar.bz2
gentoo-a137f4733ab32516a59f1826a6d491630b1db363.zip
app-emulation/diskimage-builder: 2.29.1 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder/diskimage-builder-2.29.1.ebuild')
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.29.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.29.1.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.29.1.ebuild
new file mode 100644
index 000000000000..86d3bb124b34
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.29.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"