summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-04-01 00:23:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-04-01 00:23:48 +0200
commit2ea0d6a6b0414c7df16076f732650ce4dbb59fa8 (patch)
tree905217775aebdbbef8a1f6f426ec8617aee1a5e3 /app-emulation/docker-compose
parentdev-util/pycharm-professional: Version bump to 2018.1 (diff)
downloadgentoo-2ea0d6a6b0414c7df16076f732650ce4dbb59fa8.tar.gz
gentoo-2ea0d6a6b0414c7df16076f732650ce4dbb59fa8.tar.bz2
gentoo-2ea0d6a6b0414c7df16076f732650ce4dbb59fa8.zip
app-emulation/docker-compose: Version bump to 1.20.1
Closes: https://bugs.gentoo.org/651090 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.20.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 494ca3180466..aa474faccb02 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,2 +1,3 @@
DIST docker-compose-1.18.0.tar.gz 231256 BLAKE2B be9b57dd89a81734b850f61622a924a3ace5ace907c4d1365a18315ddfbe3f1a9a56b222766980d16d5eddbe6818caf94a5833c5cddac082fa230bf290977ee3 SHA512 9cf29d892f6419e9ef639e1b9edddecb47ddb5ba7f97830f732e463ee510ac5464d6d81f58a2bf4ae5e7aee78b3d2d4afd59e6e1b53974899edb3e090bcb991f
DIST docker-compose-1.19.0.tar.gz 238307 BLAKE2B 2a7bbcf50c2cc591eba1d59db30cb0341e33e3f1ebe948e0b6762d9bffcdcc72d98e2da19fc549c5fabda192fca69a9d54e016601ddb4f4a94f0dc1c93f99a29 SHA512 f1d522621580a5130378508e6b15ad2e4708e9c5ff713627ca54308ab3e6bf000e21c55bbdf9585b2116e73648fdc773500a5415ab81a72dd2c69c9c07e71581
+DIST docker-compose-1.20.1.tar.gz 246159 BLAKE2B 32836f06239d6f1506ecebac48c8b56c58620d0ba309b8469c073ec3b048bf3743afb1ff6f63d2031df4bb316191d9cd32d5cf85a2cb86544254c6054a7dd502 SHA512 faba24ea501c4e4aaf04bddf1d498eaa7702385458ac7a41f6054e9153f9e03e1e6f50aebc5156d6a814d567aedea1d16ff532872a1765bbabbd3c8da47e36e0
diff --git a/app-emulation/docker-compose/docker-compose-1.20.1.ebuild b/app-emulation/docker-compose/docker-compose-1.20.1.ebuild
new file mode 100644
index 000000000000..9e085b82c016
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.20.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.1.4[${PYTHON_USEDEP}]
+ <dev-python/docker-py-4.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+ <dev-python/requests-2.19[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.10[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}