summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-22 15:15:01 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-22 15:15:20 -0600
commit80c16b295b7b7f5027faf44def69c7c05dc3ac95 (patch)
treef60af07dc5c775911deeb24fe2e7e0b3f9983b2a /app-emulation/docker-compose
parentdev-java/gcj-jdk: Remove old (diff)
downloadgentoo-80c16b295b7b7f5027faf44def69c7c05dc3ac95.tar.gz
gentoo-80c16b295b7b7f5027faf44def69c7c05dc3ac95.tar.bz2
gentoo-80c16b295b7b7f5027faf44def69c7c05dc3ac95.zip
app-emulation/docker-compose: add version 1.5.1
Fixes bug #560596. Package-Manager: portage-2.2.25
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.5.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index a2bae4afaf3c..84ee15228646 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,2 +1,3 @@
DIST docker-compose-1.2.0.tar.gz 57150 SHA256 46ef3c5cb7dd79fa7fd1d5fc5ec5be6a5c634192bc09c604c0ea75adb89cb652 SHA512 d13f6d6d22979dbc4554c003e611097627e2273f06dd13a1c666c1ba138288597ebef08f1beaf6d342721391cb49ad5ce9ae2ff03367a041fc0c53fbb62c9ac4 WHIRLPOOL c7bb3e14a4c2788eb49241ce02dcaed5e49fe60652ca1a51d13e1712f946046415f5397d5bf892b5e0451059a4aee1b156ee7bdfdf64a22d000caae7b17254c0
DIST docker-compose-1.4.0.tar.gz 79532 SHA256 2748cc8dd0829b44f0f686e36683cab58e1a4bc869442a04508504d2f62d0337 SHA512 470442aa78ddb24e8b9287953031e17a96a89780edd3a85955c923ffe00f4bfe655412dc15422437121593d7e2899f0847813d3716fc9ed576f93e6455cb868b WHIRLPOOL 9dc6731dad3df6422ec1e1b66049c8e9f04068b2fc2c8180da44220c1fbedc4919dfe17475cd539c3f33a079f3d04f875baaf769a7bc0875de48cf622670dc4b
+DIST docker-compose-1.5.1.tar.gz 104331 SHA256 df5e885fd758a2b5983574d6718b5a07f92c7166c5706dc6ff88687d27bfaf55 SHA512 be6678c27b73516e14bf80255e52bde72517bd65a91f1be2393a15f0f0b87ff9ddd785e22016a9a5e1a68d5e6b9be395a96d60b7bc862f24647adf81752b9baa WHIRLPOOL 0b1312cb0d99a7cf02d8a88a7b00f3105f497c1cfa0ac3b32b369cd3984f2b1eaa8ea2c9e2e5a70ada3a371fb8a774245b75eaf5a7665170398df5f703793311
diff --git a/app-emulation/docker-compose/docker-compose-1.5.1.ebuild b/app-emulation/docker-compose/docker-compose-1.5.1.ebuild
new file mode 100644
index 000000000000..e988d1938a47
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.5.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.3.4[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.4[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-1.5.0[${PYTHON_USEDEP}]
+ <dev-python/docker-py-2[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}