summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Kitover <rkitover@gmail.com>2019-08-09 19:55:21 +0000
committerJoonas Niilola <juippis@gentoo.org>2019-08-10 08:06:41 +0300
commit967e6e8779995d82dfcee5313447ba9dc72280ac (patch)
treea427086a0bcbc742e1f8908d7c1741eaa2973ddb /app-emulation/docker-credential-helpers/docker-credential-helpers-0.6.3.ebuild
parentprofiles: Drop outdated masks on alpha (diff)
downloadgentoo-967e6e8779995d82dfcee5313447ba9dc72280ac.tar.gz
gentoo-967e6e8779995d82dfcee5313447ba9dc72280ac.tar.bz2
gentoo-967e6e8779995d82dfcee5313447ba9dc72280ac.zip
app-emulation/docker-credential-helpers: add 0.6.3
Both stores tested to work correctly. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Rafael Kitover <rkitover@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12637 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation/docker-credential-helpers/docker-credential-helpers-0.6.3.ebuild')
-rw-r--r--app-emulation/docker-credential-helpers/docker-credential-helpers-0.6.3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/docker-credential-helpers/docker-credential-helpers-0.6.3.ebuild b/app-emulation/docker-credential-helpers/docker-credential-helpers-0.6.3.ebuild
new file mode 100644
index 000000000000..3f46440c7bba
--- /dev/null
+++ b/app-emulation/docker-credential-helpers/docker-credential-helpers-0.6.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A suite of programs to use native stores to keep Docker credentials safe"
+HOMEPAGE="https://github.com/docker/docker-credential-helpers"
+EGO_PN=github.com/docker/docker-credential-helpers
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+IUSE="gnome-keyring pass"
+REQUIRED_USE="|| ( gnome-keyring pass )"
+RESTRICT="test"
+
+DEPEND="gnome-keyring? ( app-crypt/libsecret )"
+
+RDEPEND="(
+ ${DEPEND}
+ pass? ( app-admin/pass )
+)
+"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ local -x GOPATH="${WORKDIR}/${P}"
+ use gnome-keyring && emake secretservice
+ use pass && emake pass
+}
+
+src_install() {
+ dobin bin/*
+ dodoc CHANGELOG.md MAINTAINERS README.md
+}
+
+pkg_postinst() {
+ if use gnome-keyring; then
+ elog "For gnome-keyring/kwallet add:\n"
+ elog ' "credStore": "secretservice"'"\n"
+ fi
+ if use pass; then
+ elog "For 'pass' add:\n"
+ elog ' "credStore": "pass"'"\n"
+ fi
+ elog "to your ~/.docker/config.json"
+}