summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-06-06 17:42:42 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-06-06 17:42:42 +0200
commitde705a2227df237bd7d8ae8aa417a78ef87b1434 (patch)
treeb5a27fafec51d69b4aaa74e076fd376744668939 /app-emulation/docker-proxy/docker-proxy-0.8.0_p20190513.ebuild
parentnet-misc/memcached: arm64 stable (tested local) (diff)
downloadgentoo-de705a2227df237bd7d8ae8aa417a78ef87b1434.tar.gz
gentoo-de705a2227df237bd7d8ae8aa417a78ef87b1434.tar.bz2
gentoo-de705a2227df237bd7d8ae8aa417a78ef87b1434.zip
app-emulation/docker-proxy: Update snapshot for 18.09.7
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20190513.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20190513.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190513.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190513.ebuild
new file mode 100644
index 000000000000..1fccabf5362e
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190513.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="e7933d41e7b206756115aa9df5e0599fc5169742"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test" # needs dockerd
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc ROADMAP.md README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}