summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-07-29 11:05:11 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-07-29 11:05:43 +0200
commit038a9a6bd5173be886bd6abf864121752541abf0 (patch)
tree63f45c864eb0e3643fd5edb9497545af94b52a55 /app-emulation/docker-proxy/docker-proxy-0.8.0_p20190604.ebuild
parentapp-arch/zstd: Version bump to 1.4.2 (diff)
downloadgentoo-038a9a6bd5173be886bd6abf864121752541abf0.tar.gz
gentoo-038a9a6bd5173be886bd6abf864121752541abf0.tar.bz2
gentoo-038a9a6bd5173be886bd6abf864121752541abf0.zip
app-emulation/docker-proxy: Update snapshot for docker-19.03.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20190604.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20190604.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190604.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190604.ebuild
new file mode 100644
index 000000000000..4400a3255a11
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190604.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="fc5a7d91d54cc98f64fc28f9e288b46a0bee756c"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test" # needs dockerd
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}