summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-03-28 15:49:58 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-03-28 15:49:58 +0100
commitc39363c64194e077285877d8ec6cc5ddd784eed5 (patch)
treea6e272aedeac9dad440ff000731cfeed2ae25014 /app-emulation/docker-proxy
parentapp-emulation/containerd: Stabilize on amd64 (diff)
downloadgentoo-c39363c64194e077285877d8ec6cc5ddd784eed5.tar.gz
gentoo-c39363c64194e077285877d8ec6cc5ddd784eed5.tar.bz2
gentoo-c39363c64194e077285877d8ec6cc5ddd784eed5.zip
app-emulation/docker-proxy: Update snapshot
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/docker-proxy')
-rw-r--r--app-emulation/docker-proxy/Manifest1
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20190301.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/Manifest b/app-emulation/docker-proxy/Manifest
index d17172379480..44ff02e9d388 100644
--- a/app-emulation/docker-proxy/Manifest
+++ b/app-emulation/docker-proxy/Manifest
@@ -2,3 +2,4 @@ DIST docker-proxy-0.8.0_p20180411.tar.gz 2695069 BLAKE2B 5205d5700ad116bb457dc7a
DIST docker-proxy-0.8.0_p20180626.tar.gz 2718698 BLAKE2B 6214ba714ba8b01214168171f465dfaee4d8ff791db7a219a3fb92fade3e4207d36d90090790c0a3059e6fb209f3cd8bb0082ca75496108ebffb7c9b0c5092a4 SHA512 21d3d1bd8aafeab51a3e0a14ada4d559b5b113a48d315e91f7d70e4fa839f5c92d4068b38c28bf6929da9c11cfc61703bafc7148f64b784208d61fa14ee4545d
DIST docker-proxy-0.8.0_p20180907.tar.gz 2711336 BLAKE2B ad1fc76347058610e2cd1659fb89f9990cc704c3a31006b976e44f31a30e754ac86e7b4823c48461cdcba948bb8d320ae25eac1e13b26f1fde072343251a61e0 SHA512 603ad154d0987a021dae69d542fa82a53b8d25ad9b44cf16f0ef551e0b81e0174dcc73b3a8e9ba89ca1d209f0022e767d44a8350b00b9b4e252cfab698b1d5bd
DIST docker-proxy-0.8.0_p20181207.tar.gz 2703206 BLAKE2B 46b71a4d6ac9eb0659a45c1956eb967a73b2b73c446d55de3a5b4014149f911daa03c6a914e8d79da53e01892c6592adf0df769b6b5ed3b41f3c4a3c9f979da3 SHA512 9256eedc6ed530506e4e61673a9f45397274093dd61105097d5c650796f0afebc8ad7c550d2dc3cacf94426e3872a2b764906bca46fc907a21b865314c8927d4
+DIST docker-proxy-0.8.0_p20190301.tar.gz 2703026 BLAKE2B 0d0da49e1daf260c5d5699cfa8dd447cd6fe83f5903834aa065af52f133910d1f16a06ef7688340d2068e5ac544de8b1a2b9644f65af486077b66d56efd9447f SHA512 8ffd6fc97df4b63b1f83a5eb6d8e63c8c413bcf3e2ff82f507dbf875d0df6903b6fe1546d8625dd3b4681d611aed4702c423d0d5c9621ed57073cbe16bf35200
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190301.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190301.ebuild
new file mode 100644
index 000000000000..ed5d2bce09cd
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20190301.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="4725f2163fb214a6312f3beae5991f838ec36326"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RDEPEND="!<app-emulation/docker-1.13.0_rc1"
+
+RESTRICT="test" # needs dockerd
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc ROADMAP.md README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}