summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-01 15:09:01 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-01 15:13:24 -0700
commit0eea13ca58aba2306a979fdc0bd307bccedbfe60 (patch)
treefd4cdf614990ecdf9652b9179080b9f831cf4d24 /app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
parentsys-cluster/nova: removing unneeded init script (diff)
downloadgentoo-0eea13ca58aba2306a979fdc0bd307bccedbfe60.tar.gz
gentoo-0eea13ca58aba2306a979fdc0bd307bccedbfe60.tar.bz2
gentoo-0eea13ca58aba2306a979fdc0bd307bccedbfe60.zip
app-emulation/docker-registry: revbump to 2.6.2-r1 for bug 629202
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild')
-rw-r--r--app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild b/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
new file mode 100644
index 000000000000..6ea2a86bd59b
--- /dev/null
+++ b/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-vcs-snapshot systemd user
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/docker/distribution"
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Docker Registry 2.0"
+HOMEPAGE="https://github.com/docker/distribution"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+SVCNAME=registry
+
+PATCHES=( "${FILESDIR}/${PN}-2.6.1-notifications-expvar.patch" )
+
+pkg_setup() {
+ enewgroup ${SVCNAME}
+ enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME}
+}
+
+src_compile() {
+ GOPATH="${S}" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die
+}
+
+src_install() {
+ exeinto /usr/libexec/${PN}
+ doexe bin/*
+ insinto /etc/docker/registry
+ newins src/${EGO_PN}/cmd/registry/config-example.yml config.yml.example
+ newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
+ newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
+ systemd_dounit "${FILESDIR}/${SVCNAME}.service"
+ keepdir /var/{lib,log}/${SVCNAME}
+ fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
+}