summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-01-08 12:12:32 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-01-08 12:13:09 -0600
commit8a2bc214ed5a9607bd2e19178af4782b0965b34b (patch)
treeef59efe98099780a25f81f3beeae5a2999414769 /app-emulation/docker
parentapp-emulation/docker: 20.10.2 bump (diff)
downloadgentoo-8a2bc214ed5a9607bd2e19178af4782b0965b34b.tar.gz
gentoo-8a2bc214ed5a9607bd2e19178af4782b0965b34b.tar.bz2
gentoo-8a2bc214ed5a9607bd2e19178af4782b0965b34b.zip
app-emulation/docker-cli: 20.10.2 qa-requested changes
- unpin the docker-cli version - use the "cli" global use flag for the command line interface but note it is being used temporarily. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation/docker')
-rw-r--r--app-emulation/docker/docker-20.10.2.ebuild11
-rw-r--r--app-emulation/docker/metadata.xml12
2 files changed, 11 insertions, 12 deletions
diff --git a/app-emulation/docker/docker-20.10.2.ebuild b/app-emulation/docker/docker-20.10.2.ebuild
index fc76d42b04c5..7853e583ce81 100644
--- a/app-emulation/docker/docker-20.10.2.ebuild
+++ b/app-emulation/docker/docker-20.10.2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/moby/moby/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="apparmor aufs btrfs +container-init device-mapper hardened overlay seccomp +temp-cli"
+IUSE="apparmor aufs btrfs +cli +container-init device-mapper hardened overlay seccomp"
DEPEND="
acct-group/docker
@@ -40,8 +40,8 @@ RDEPEND="
~app-emulation/containerd-1.4.3[apparmor?,btrfs?,device-mapper?,seccomp?]
~app-emulation/runc-1.0.0_rc92[apparmor?,seccomp?]
~app-emulation/docker-proxy-0.8.0_p20201211
+ cli? ( app-emulation/docker-cli )
container-init? ( >=sys-process/tini-0.19.0[static] )
- temp-cli? ( ~app-emulation/docker-cli-${PV} )
"
# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
@@ -270,20 +270,19 @@ pkg_postinst() {
elog
fi
- if use temp-cli; then
+ if use cli; then
ewarn "Starting with docker 20.10.2, docker has been split into"
ewarn "two packages upstream, so Gentoo has followed suit."
ewarn
ewarn "app-emulation/docker contains the daemon and"
ewarn "app-emulation/docker-cli contains the docker command."
ewarn
- ewarn "docker currently installs docker-cli using the temp-cli"
- ewarn "use flag."
+ ewarn "docker currently installs docker-cli using the cli use flag."
ewarn
ewarn "This use flag is temporary, so you need to take the"
ewarn "following actions:"
ewarn
- ewarn "First, disable the temp-cli use flag for app-emulation/docker"
+ ewarn "First, disable the cli use flag for app-emulation/docker"
ewarn
ewarn "Then, if you need docker-cli and docker on the same machine,"
ewarn "run the following command:"
diff --git a/app-emulation/docker/metadata.xml b/app-emulation/docker/metadata.xml
index 93b6a7a30980..1ec7d353074c 100644
--- a/app-emulation/docker/metadata.xml
+++ b/app-emulation/docker/metadata.xml
@@ -28,6 +28,12 @@
Enables dependencies for the "btrfs" graph driver, including
necessary kernel flags.
</flag>
+ <flag name="cli">
+ This is a temporary use flag which pulls in
+ app-emulation/docker-cli, the docker command line client.
+ This flag is here to assist in the transition to split packages
+ and will be removed in a future release.
+ </flag>
<flag name="container-init">
Makes the a staticly-linked init system tini available inside a
container.
@@ -40,12 +46,6 @@
Enables dependencies for the "overlay" graph driver, including
necessary kernel flags.
</flag>
- <flag name="temp-cli">
- This is a temporary use flag which pulls in
- app-emulation/docker-cli, the docker command line client.
- This flag is here to assist in the transition to split packages
- and will be removed in a future release.
- </flag>
</use>
<upstream>
<remote-id type="github">moby/moby</remote-id>