summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-04-04 22:39:22 -0400
committerMike Gilbert <floppym@gentoo.org>2021-04-05 11:34:46 -0400
commitca7b7f97a997ca003915690316712dcfe98f353f (patch)
tree8a0cc37cf0e9ecbb46ab1d26852dcf914c508859 /app-emulation/docker
parentapp-emulation/docker-cli: avoid using ROOT in src_compile (diff)
downloadgentoo-ca7b7f97a997ca003915690316712dcfe98f353f.tar.gz
gentoo-ca7b7f97a997ca003915690316712dcfe98f353f.tar.bz2
gentoo-ca7b7f97a997ca003915690316712dcfe98f353f.zip
app-emulation/docker: avoid using ROOT in src_compile
ESYSROOT should be used to locate headers and libraries. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-emulation/docker')
-rw-r--r--app-emulation/docker/docker-19.03.15.ebuild4
-rw-r--r--app-emulation/docker/docker-20.10.5.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-emulation/docker/docker-19.03.15.ebuild b/app-emulation/docker/docker-19.03.15.ebuild
index 848e9be75a8f..264b79cadde4 100644
--- a/app-emulation/docker/docker-19.03.15.ebuild
+++ b/app-emulation/docker/docker-19.03.15.ebuild
@@ -194,8 +194,8 @@ src_compile() {
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
# if we're building from a tarball, we need the GITCOMMIT value
[[ ${DOCKER_GITCOMMIT} ]] && export DOCKER_GITCOMMIT
diff --git a/app-emulation/docker/docker-20.10.5.ebuild b/app-emulation/docker/docker-20.10.5.ebuild
index 46bb5af09cda..0d576b0ffc80 100644
--- a/app-emulation/docker/docker-20.10.5.ebuild
+++ b/app-emulation/docker/docker-20.10.5.ebuild
@@ -165,8 +165,8 @@ src_compile() {
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
# let's set up some optional features :)
export DOCKER_BUILDTAGS=''