summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-02-02 12:38:05 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2017-02-02 12:38:25 +0100
commita6c4fdf84d1158c9c87af32e587a2726796f66d7 (patch)
tree9b5eabc3ae5ca74e5c93c96221713359bec03291 /app-emulation/free42/files
parentapp-backup/cdbkup: remove old (diff)
downloadgentoo-a6c4fdf84d1158c9c87af32e587a2726796f66d7.tar.gz
gentoo-a6c4fdf84d1158c9c87af32e587a2726796f66d7.tar.bz2
gentoo-a6c4fdf84d1158c9c87af32e587a2726796f66d7.zip
app-emulation/free42: Bumps version to 1.5.13
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-emulation/free42/files')
-rw-r--r--app-emulation/free42/files/free42-1.5.13-fix-build-intel-lib.patch12
-rw-r--r--app-emulation/free42/files/free42-1.5.13-fix-makefile.patch57
2 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/free42/files/free42-1.5.13-fix-build-intel-lib.patch b/app-emulation/free42/files/free42-1.5.13-fix-build-intel-lib.patch
new file mode 100644
index 000000000000..23641b552f27
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.13-fix-build-intel-lib.patch
@@ -0,0 +1,12 @@
+diff -Nuar a/gtk/build-intel-lib.sh b/gtk/build-intel-lib.sh
+--- a/gtk/build-intel-lib.sh 2016-09-04 18:56:12.000000000 +0200
++++ b/gtk/build-intel-lib.sh 2016-09-24 19:39:49.284126118 +0200
+@@ -4,7 +4,7 @@
+ cd IntelRDFPMathLib20U1
+ patch -p0 <../intel-lib-linux.patch
+ cd LIBRARY
+-make CC=gcc CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0
++make A=a CC=gcc CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0
+ mv libbid.a ../../gcc111libbid.a
+ cd ../..
+ ( echo '#ifdef FREE42_FPTEST'; echo 'const char *readtest_lines[] = {'; tr -d '\r' < IntelRDFPMathLib20U1/TESTS/readtest.in | sed 's/^\(.*\)$/"\1",/'; echo '0 };'; echo '#endif' ) > readtest_lines.cc
diff --git a/app-emulation/free42/files/free42-1.5.13-fix-makefile.patch b/app-emulation/free42/files/free42-1.5.13-fix-makefile.patch
new file mode 100644
index 000000000000..29c3bb5f5e5e
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.13-fix-makefile.patch
@@ -0,0 +1,57 @@
+diff -Nuar a/gtk/Makefile b/gtk/Makefile
+--- a/gtk/Makefile 2016-10-04 03:45:02.000000000 +0200
++++ b/gtk/Makefile 2016-11-26 22:06:25.599990576 +0100
+@@ -15,11 +15,10 @@
+ # along with this program; if not, see http://www.gnu.org/licenses/.
+ ###############################################################################
+
+-CFLAGS = -MMD \
++CFLAGS := -MMD \
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
+- -g \
+ -I/usr/X11R6/include \
+ $(shell pkg-config --cflags gtk+-2.0) \
+ -DVERSION="\"$(shell cat ../VERSION)\"" \
+@@ -27,21 +26,25 @@
+ -DDECIMAL_GLOBAL_ROUNDING=1 \
+ -DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+- -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1
++ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
++ ${CFLAGS}
+
+-CXXFLAGS = $(CFLAGS) \
++CXXFLAGS := $(CFLAGS) \
+ -fno-exceptions \
+ -fno-rtti \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+-LDFLAGS = -L/usr/X11R6/lib
++MYLDFLAGS = -L/usr/X11R6/lib
+-LIBS = gcc111libbid.a -lXmu $(shell pkg-config --libs gtk+-2.0)
++LIBS = gcc111libbid.a -lX11 -ldl -lXmu $(shell pkg-config --libs gtk+-2.0)
+
+ ifeq "$(shell uname -s)" "Linux"
+-LDFLAGS += -Wl,--hash-style=both
++MYLDFLAGS += -Wl,--hash-style=both
+ LIBS += -lpthread
+ endif
+
++MYLDFLAGS += ${LDFLAGS}
++
+ SRCS = shell_main.cc shell_skin.cc skins.cc keymap.cc shell_loadimage.cc \
+ shell_spool.cc core_main.cc core_commands1.cc core_commands2.cc \
+ core_commands3.cc core_commands4.cc core_commands5.cc \
+@@ -83,7 +86,7 @@
+ endif
+
+ $(EXE): $(OBJS)
+- $(CXX) -o $(EXE) $(LDFLAGS) $(OBJS) $(LIBS)
++ $(CXX) -o $(EXE) $(MYLDFLAGS) $(OBJS) $(LIBS)
+
+ $(SRCS) skin2cc.cc keymap2cc.cc skin2cc.conf: symlinks
+