summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/ganeti-instance-image
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/ganeti-instance-image')
-rw-r--r--app-emulation/ganeti-instance-image/Manifest1
-rw-r--r--app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild51
-rw-r--r--app-emulation/ganeti-instance-image/metadata.xml10
3 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/ganeti-instance-image/Manifest b/app-emulation/ganeti-instance-image/Manifest
new file mode 100644
index 000000000000..37f8ab3257db
--- /dev/null
+++ b/app-emulation/ganeti-instance-image/Manifest
@@ -0,0 +1 @@
+DIST ganeti-instance-image-0.6.tar.gz 82534 SHA256 eb8cd0a26acc5b2bd651a1e014688a9f395cef35b4f6393df6a53aeadae1d2fc SHA512 92b5048fe8c40692e8e7c4cb73b21e764660d7cb5f585a8489fc4338eef7df8aae1147d38a849103585a884a0216a0bfb42473d5c1922130e5aada31f5d580c3 WHIRLPOOL d4b04066ad3d11ff995710a7f8932a203a8bc5acb22abe2b202b0e5a84c1075f4f0c7a9d8a18111915abc04a7f67630590edf9f1c520ea6f5960c9e920aa294a
diff --git a/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild
new file mode 100644
index 000000000000..589eafa60b73
--- /dev/null
+++ b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://git.osuosl.org/${PN}.git"
+ EGIT_BRANCH="master"
+ inherit git-2 autotools
+else
+ SRC_URI="http://ftp.osuosl.org/pub/osl/ganeti-instance-image/${P}.tar.gz"
+fi
+
+DESCRIPTION="Scripts to build out CD or image based VMs using Ganeti"
+HOMEPAGE="http://code.osuosl.org/projects/ganeti-image"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dump
+ >=app-emulation/ganeti-2.0.3
+ || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp )
+ app-emulation/qemu
+ sys-apps/util-linux
+ sys-fs/multipath-tools
+ sys-fs/e2fsprogs"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf --with-default-dir=/etc/ganeti
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc README.markdown NEWS ChangeLog
+ insinto /etc/ganeti
+ newins defaults ${PN}
+}
diff --git a/app-emulation/ganeti-instance-image/metadata.xml b/app-emulation/ganeti-instance-image/metadata.xml
new file mode 100644
index 000000000000..cee84c239672
--- /dev/null
+++ b/app-emulation/ganeti-instance-image/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
+