summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-07 15:37:20 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-07 17:24:37 +0100
commit978cfedeaa8ab81f979532d0a8e5f4140201cdd0 (patch)
tree441f1464052faec644bedfb7eec26a14643efb4b /app-emulation/libguestfs/files
parentapp-emulation/libguestfs-appliance: 1.36.1 → 1.38.0 (diff)
downloadgentoo-978cfedeaa8ab81f979532d0a8e5f4140201cdd0.tar.gz
gentoo-978cfedeaa8ab81f979532d0a8e5f4140201cdd0.tar.bz2
gentoo-978cfedeaa8ab81f979532d0a8e5f4140201cdd0.zip
app-emulation/libguestfs: 1.36.15 → 1.38.6
Closes: https://bugs.gentoo.org/663380 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-emulation/libguestfs/files')
-rw-r--r--app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch40
-rw-r--r--app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch45
2 files changed, 85 insertions, 0 deletions
diff --git a/app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch b/app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch
new file mode 100644
index 000000000000..cb608beca08f
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch
@@ -0,0 +1,40 @@
+From 3b06e1cbb25615495ef108d6ee194bb718e46408 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 7 Dec 2018 11:21:25 +0100
+Subject: [PATCH 1/2] Fix install failure when not built with OCaml support
+
+Makefile rules in po/ require builder/index-parse.c to be generated to
+allow translation utilities to work on it, however builder/ is
+completely masked behind OCaml conditional build even if some tools do
+not require it and proper guards are in place already.
+
+Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1614502
+---
+ Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index cc363341f..5d96093a1 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -164,7 +164,6 @@ SUBDIRS += common/mlvisit
+ SUBDIRS += common/mlxml
+ SUBDIRS += common/mltools
+ SUBDIRS += customize
+-SUBDIRS += builder builder/templates
+ SUBDIRS += get-kernel
+ SUBDIRS += resize
+ SUBDIRS += sparsify
+@@ -178,6 +177,9 @@ SUBDIRS += dib
+ endif
+ endif
+
++# Tools mixed with more OCAML based tools
++SUBDIRS += builder builder/templates
++
+ # Perl tools.
+ if HAVE_TOOLS
+ SUBDIRS += tools
+--
+2.19.2
+
diff --git a/app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch b/app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch
new file mode 100644
index 000000000000..e68a4b0bded4
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch
@@ -0,0 +1,45 @@
+From b8a31fcfe81a680ffed1fa0879ac20a3e0e8753a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 7 Dec 2018 12:14:15 +0100
+Subject: [PATCH 2/2] Loosen build time requirement on bash-completion
+
+Distributions might avoid pulling bash-completion during build as it is
+an optional feature and would only make sense at runtime anyway. Since
+this setting is well-known across a given distribution, allow them to
+provide the value and avoid the dependency.
+---
+ m4/guestfs-bash-completion.m4 | 21 ++++++++++-----------
+ 1 file changed, 10 insertions(+), 11 deletions(-)
+
+diff --git a/m4/guestfs-bash-completion.m4 b/m4/guestfs-bash-completion.m4
+index 1975b8c03..9a38ab2d6 100644
+--- a/m4/guestfs-bash-completion.m4
++++ b/m4/guestfs-bash-completion.m4
+@@ -16,14 +16,13 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+ dnl Bash completion.
+-PKG_CHECK_MODULES([BASH_COMPLETION], [bash-completion >= 2.0], [
+- bash_completion=yes
+- AC_MSG_CHECKING([for bash-completions directory])
+- BASH_COMPLETIONS_DIR="`pkg-config --variable=completionsdir bash-completion`"
+- AC_MSG_RESULT([$BASH_COMPLETIONS_DIR])
+- AC_SUBST([BASH_COMPLETIONS_DIR])
+-],[
+- bash_completion=no
+- AC_MSG_WARN([bash-completion not installed])
+-])
+-AM_CONDITIONAL([HAVE_BASH_COMPLETION],[test "x$bash_completion" = "xyes"])
++AC_ARG_WITH([bashcompletiondir],
++ AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),
++ [],
++ [AS_IF([$($PKG_CONFIG --exists bash-completion)], [
++ with_bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
++ ] , [
++ with_bashcompletiondir=${datadir}/bash-completion/completions
++ ])])
++AC_SUBST([BASH_COMPLETIONS_DIR], [$with_bashcompletiondir])
++AM_CONDITIONAL([HAVE_BASH_COMPLETION],[test -n "$with_bashcompletiondir"])
+--
+2.19.2
+