summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-01-30 11:39:01 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-01-30 11:54:56 -0600
commit0a987006baf8f3267fb9df03e16baab99bf1f98b (patch)
tree6364c223794fa7a094f1186474ecfb17a84b90d3 /app-emulation/libvirt/libvirt-9999.ebuild
parentdev-python/libvirt-python: version bump to 4.0.0 (diff)
downloadgentoo-0a987006baf8f3267fb9df03e16baab99bf1f98b.tar.gz
gentoo-0a987006baf8f3267fb9df03e16baab99bf1f98b.tar.bz2
gentoo-0a987006baf8f3267fb9df03e16baab99bf1f98b.zip
app-emulation/libvirt: add bashcompletion support
- also apply two minor bugfixes for version 4.0.0 (hopefully fixed in the live version soon.) Closes: https://bugs.gentoo.org/644632 Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-emulation/libvirt/libvirt-9999.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 3716e896837b..84ae6b580a78 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils user linux-info systemd readme.gentoo-r1
+inherit autotools eutils user linux-info systemd readme.gentoo-r1 bash-completion-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
@@ -355,6 +355,9 @@ src_install() {
newconfd "${FILESDIR}/libvirtd.confd-r5" libvirtd || die
newconfd "${FILESDIR}/libvirt-guests.confd" libvirt-guests || die
+ newbashcomp "${S}/tools/bash-completion/vsh" vsh
+ bashcomp_alias vsh virsh virt-admin
+
DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r2")
DISABLE_AUTOFORMATTING=true
readme.gentoo_create_doc