summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-03-20 11:48:17 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-03-20 11:48:17 -0500
commitfb16688c4cc31556dfd229169195990027ced0d1 (patch)
tree6898fcd6e0e8cf6cc940462171d2ef59591db5ef /app-emulation/libvirt/libvirt-9999.ebuild
parentapp-emulation/libvirt: 4.1.0-r1 try to fix the network mess... (diff)
downloadgentoo-fb16688c4cc31556dfd229169195990027ced0d1.tar.gz
gentoo-fb16688c4cc31556dfd229169195990027ced0d1.tar.bz2
gentoo-fb16688c4cc31556dfd229169195990027ced0d1.zip
app-emulation/libvirt: Update live ebuild, ebuild maintenance
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation/libvirt/libvirt-9999.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 0b482d5c1023..7aff7685c709 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -58,6 +58,8 @@ RDEPEND="
|| ( >=net-analyzer/netcat6-1.0-r2 >=net-analyzer/openbsd-netcat-1.105-r1 )
>=net-libs/gnutls-1.0.25:0=
net-libs/libssh2
+ net-libs/libtirpc
+ net-libs/rpcsvc-proto
>=net-misc/curl-7.18.0
sys-apps/dmidecode
>=sys-apps/util-linux-2.17
@@ -235,6 +237,12 @@ src_prepare() {
}
src_configure() {
+ #
+ # With 4.1.0 we should always enable networking support - otherwise not
+ # even minimal networking is available. Yes, this degrades
+ # USE=virt-network to a mere runtime-dep USE flag. But let's keep it
+ # for compatibility and convenience.
+ #
local myeconfargs=(
$(use_with apparmor)
$(use_with apparmor apparmor-profiles)
@@ -268,7 +276,6 @@ src_configure() {
$(use_with udev)
$(use_with uml)
$(use_with vepa virtualport)
- $(use_with virt-network network)
$(use_with wireshark-plugins wireshark-dissector)
$(use_with xen)
$(use_with xen xen-inotify)
@@ -276,6 +283,8 @@ src_configure() {
$(use_with zeroconf avahi)
$(use_with zfs storage-zfs)
+ --with-network
+
--without-hal
--without-netcf
--without-sanlock