summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <hsoft@hardcoded.net>2018-04-10 21:14:59 -0400
committerMatthias Maier <tamiko@gentoo.org>2018-04-25 20:35:49 -0500
commitba77a0dedea123401b3015213dbcf6e1b9d44471 (patch)
tree2ec1541224d73a1135548ec27931f556dc08ce64 /app-emulation/lxc/files
parentwww-apps/hugo: Version bump to 0.40.1 (diff)
downloadgentoo-ba77a0dedea123401b3015213dbcf6e1b9d44471.tar.gz
gentoo-ba77a0dedea123401b3015213dbcf6e1b9d44471.tar.bz2
gentoo-ba77a0dedea123401b3015213dbcf6e1b9d44471.zip
app-emulation/lxc: Bump to v3.0.0
Many notable changes: 1. Drop python and lua. Bindings are no longer bundled with LXC and live in separate packages. 2. Drop cgmanager USE flag. cgmanager isn't supported anymore by upstream. 3. Remove versionator inherit. It wasn't used. 4. Remove two patches which were simple cherry pick from upstreams. They're applied upstream now. 5. Remove notice about path change in v1.1. It's been a while, it lost relevance. 6. Remove start-ephemeral bash completion. Upstream finally removed it from its own completions. 7. Add "pam" USE flag for the compilation and installation of the new builtin "pam_cgfs.so" module. Closes: https://bugs.gentoo.org/652582 Closes: https://github.com/gentoo/gentoo/pull/7934 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-3.0.0-bash-completion.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-3.0.0-bash-completion.patch b/app-emulation/lxc/files/lxc-3.0.0-bash-completion.patch
new file mode 100644
index 000000000000..2a08eedb1c2d
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-3.0.0-bash-completion.patch
@@ -0,0 +1,27 @@
+diff --git a/config/bash/lxc.in b/config/bash/lxc.in
+index 43056882..0a22d4ad 100644
+--- a/config/bash/lxc.in
++++ b/config/bash/lxc.in
+@@ -1,4 +1,3 @@
+-_have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -108,4 +107,3 @@ _have lxc-start && {
+ complete -o default -F _lxc_generic_t lxc-create
+
+ complete -o default -F _lxc_generic_o lxc-copy
+-}
+diff --git a/configure.ac b/configure.ac
+index 50c99836..0569caec 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -395,7 +395,7 @@ AM_CONDITIONAL([ENABLE_BASH], [test "x$enable_bash" = "xyes"])
+ AM_COND_IF([ENABLE_BASH],
+ [AC_MSG_CHECKING([bash completion directory])
+ PKG_CHECK_VAR(bashcompdir, [bash-completion], [completionsdir], ,
+- bashcompdir="${sysconfdir}/bash_completion.d")
++ bashcompdir="$datadir/bash-completion/completions")
+ AC_MSG_RESULT([$bashcompdir])
+ AC_SUBST(bashcompdir)
+ ])