summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-10-13 09:52:51 +0200
committerPatrice Clement <monsieurp@gentoo.org>2021-10-13 09:54:00 +0200
commit9dd6f0120434320775dd813f786fe75cc5085d86 (patch)
tree773613421e88e6d60008323a08e74748f58a0e82 /app-emulation/nemu
parentkde-plasma/plasma-workspace: Drop 5.22.5-r1 (diff)
downloadgentoo-9dd6f0120434320775dd813f786fe75cc5085d86.tar.gz
gentoo-9dd6f0120434320775dd813f786fe75cc5085d86.tar.bz2
gentoo-9dd6f0120434320775dd813f786fe75cc5085d86.zip
app-emulation/nemu: revert bump.
Restore nemu version 2.5.0. Bug: https://bugs.gentoo.org/817821 Closes: https://bugs.gentoo.org/817968 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-emulation/nemu')
-rw-r--r--app-emulation/nemu/Manifest2
-rw-r--r--app-emulation/nemu/metadata.xml10
-rw-r--r--app-emulation/nemu/nemu-2.5.0-r1.ebuild (renamed from app-emulation/nemu/nemu-3.0.0.ebuild)15
3 files changed, 8 insertions, 19 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index c625274b1045..52a97fcdc535 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -1 +1 @@
-DIST nemu-3.0.0.tar.gz 151223 BLAKE2B a71875eb727eed13bc252cee072e1c5b25bf7ea106f51ddddfb8e8bfacf21e030b1c4045de2353d40121b78756b131de1a376891197f6d553430b4b30f53bf3e SHA512 59dae5364659dda5d7c05ba6378b6e20c5d2c5b619cb919c49036918a887574b75f5d568cbfa8f21ecf790778c9de55266f5c5e3e90cc991f613a6408b10a1df
+DIST nemu-2.5.0.tar.gz 108742 BLAKE2B e68cbf50d56983873656d8e3428cb3ffaa09cafc9cbc8e545d72bf9dfb61e64a06bdc41c3f50011c4c488017efe33afe9fa1d634aae6e9151c45a7d3971c60db SHA512 081199413c41e545d23704091760c4a10b8dcdb21d9d0e6add1e549fa33bdd988490034767e08dee681eee6d06899104b8282cafc4578e06a0eabc505325bbdc
diff --git a/app-emulation/nemu/metadata.xml b/app-emulation/nemu/metadata.xml
index 0d69beebd2d0..8976af299f5d 100644
--- a/app-emulation/nemu/metadata.xml
+++ b/app-emulation/nemu/metadata.xml
@@ -5,19 +5,11 @@
<email>monsieurp@gentoo.org</email>
<name>Patrice Clement</name>
</maintainer>
- <maintainer type="person" proxied="yes">
- <email>mail@void.so</email>
- <name>Pavel Balaev</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
<use>
<flag name="vnc-client">Adds support for external VNC client</flag>
+ <flag name="savevm">Adds support for QEMU savevm snapshots (experimental, QEMU must be patched)</flag>
<flag name="spice">Adds Spice protocol support</flag>
<flag name="ovf">Adds support for OVA/OVF import</flag>
<flag name="network-map">Adds possibility of exporting network map to SVG</flag>
- <flag name="remote-api">Adds API for remote control</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/nemu/nemu-3.0.0.ebuild b/app-emulation/nemu/nemu-2.5.0-r1.ebuild
index 5abe885a8f49..30d137f15fd9 100644
--- a/app-emulation/nemu/nemu-3.0.0.ebuild
+++ b/app-emulation/nemu/nemu-2.5.0-r1.ebuild
@@ -14,10 +14,10 @@ SRC_URI="https://github.com/nemuTUI/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.g
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="dbus network-map +ovf spice +vnc-client remote-api"
+IUSE="dbus network-map +ovf +savevm spice +vnc-client"
RDEPEND="
- >=app-emulation/qemu-6.0.0-r3[vnc,virtfs,spice?]
+ app-emulation/qemu[vnc,virtfs,spice?]
dev-db/sqlite:3=
sys-libs/ncurses:=[unicode(+)]
virtual/libusb:1
@@ -28,7 +28,6 @@ RDEPEND="
dev-libs/libxml2:2
app-arch/libarchive:=
)
- remote-api? ( dev-libs/openssl )
spice? ( app-emulation/virt-viewer )
vnc-client? ( net-misc/tigervnc )
"
@@ -52,11 +51,14 @@ pkg_pretend() {
}
src_configure() {
+ # -DNM_USE_UTF: Enable unicode unconditionally. We already
+ # depended on ncurses[unicode].
# -DNM_WITH_QEMU: Do not embbed qemu.
local mycmakeargs=(
+ -DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
+ -DNM_USE_UTF=on
-DNM_WITH_DBUS=$(usex dbus)
-DNM_WITH_NETWORK_MAP=$(usex network-map)
- -DNM_WITH_REMOTE=$(usex remote-api)
-DNM_WITH_OVF_SUPPORT=$(usex ovf)
-DNM_WITH_QEMU=off
-DNM_WITH_SPICE=$(usex spice)
@@ -65,11 +67,6 @@ src_configure() {
cmake_src_configure
}
-src_install() {
- cmake_src_install
- docompress -x /usr/share/man/man1/nemu.1.gz
-}
-
pkg_postinst() {
elog "For non-root usage execute script:"
elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"