summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-01 12:55:17 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-05 12:25:12 -0500
commit446eb1af4b73e01603c9f05c17e7f483facc4f72 (patch)
treed21abf9407d40d054fc5b9347baed5256971b85d /app-emulation/playonlinux/playonlinux-4.2.10.ebuild
parentkde-plasma: Version bump KDE Plasma 5.7.0 (diff)
downloadgentoo-446eb1af4b73e01603c9f05c17e7f483facc4f72.tar.gz
gentoo-446eb1af4b73e01603c9f05c17e7f483facc4f72.tar.bz2
gentoo-446eb1af4b73e01603c9f05c17e7f483facc4f72.zip
app-emulation/playonlinux: remove deprecated games eclass, version bump
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/playonlinux/playonlinux-4.2.10.ebuild')
-rw-r--r--app-emulation/playonlinux/playonlinux-4.2.10.ebuild116
1 files changed, 116 insertions, 0 deletions
diff --git a/app-emulation/playonlinux/playonlinux-4.2.10.ebuild b/app-emulation/playonlinux/playonlinux-4.2.10.ebuild
new file mode 100644
index 000000000000..e68076453aa5
--- /dev/null
+++ b/app-emulation/playonlinux/playonlinux-4.2.10.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2-utils python-single-r1
+
+MY_PN="PlayOnLinux"
+
+DESCRIPTION="Set of scripts to easily install and use Windows games and software"
+HOMEPAGE="http://playonlinux.com/"
+SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="winbind"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ app-crypt/gnupg
+ app-emulation/wine
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ net-misc/wget
+ x11-apps/mesa-progs
+ x11-terms/xterm
+ media-gfx/icoutils
+ || ( net-analyzer/netcat net-analyzer/netcat6 )
+ winbind? ( net-fs/samba[winbind] ) "
+
+S=${WORKDIR}/${PN}
+
+# TODO:
+# Having a real install script
+# It will let using LANGUAGES easily
+# How to deal with Microsoft Fonts installation asked every time ?
+# How to deal with wine version installed ? (have a better mgmt of system one)
+# Look at debian pkg: http://packages.debian.org/sid/playonlinux
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.4-pol-bash.patch"
+ "${FILESDIR}/${PN}-4.2.4-binary-plugin.patch"
+ "${FILESDIR}/${PN}-4.2.6-stop-update-warning.patch"
+)
+
+src_prepare() {
+ default
+
+ python_fix_shebang .
+
+ # remove playonmac
+ rm etc/{playonmac.icns,terminal.applescript} || die
+
+ # remove desktop integration
+ rm etc/{PlayOnLinux.desktop,PlayOnLinux.directory,playonlinux-Programmes.menu} || die
+}
+
+src_install() {
+ # all things without exec permissions
+ insinto "/usr/share/${PN}"
+ doins -r resources lang lib etc plugins
+
+ # bash/ install
+ exeinto "/usr/share/${PN}/bash"
+ find "${S}/bash" -type f -exec doexe '{}' +
+ exeinto "/usr/share/${PN}/bash/expert"
+ find "${S}/bash/expert" -type f -exec doexe '{}' +
+
+ # python/ install
+ python_moduleinto "/usr/share/${PN}"
+ python_domodule python
+
+ # main executable files
+ exeinto "/usr/share/${PN}"
+ doexe ${PN}{,-pkg,-bash,-shell,-url_handler}
+
+ # icons
+ doicon -s 128 etc/${PN}.png
+ for size in 16 22 32; do
+ newicon -s $size etc/${PN}$size.png ${PN}.png
+ done
+
+ doman "${FILESDIR}"/playonlinux{,-pkg}.1
+ dodoc CHANGELOG.md
+
+ make_wrapper ${PN} "./${PN}" "/usr/share/${PN}"
+ make_wrapper ${PN}-pkg "./${PN}-pkg" "/usr/share/${PN}"
+ make_desktop_entry ${PN} ${MY_PN} ${PN} Game
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Installed software and games with playonlinux have not been removed."
+ elog "To remove them, you can re-install playonlinux and remove them using it,"
+ elog "or do it manually by removing .PlayOnLinux/ in your home directory."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}