summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-17 22:06:20 +0100
committerMarek Szuba <marecki@gentoo.org>2022-01-17 22:08:01 +0100
commit7638d9eda1b084e4e42279a2d71efcad76b59f2b (patch)
treecaf8b09075dc5bd4c5b8b20c310c5ea06498ae8f /app-emulation/protontricks
parentdev-python/cerberus: add 1.3.4 (diff)
downloadgentoo-7638d9eda1b084e4e42279a2d71efcad76b59f2b.tar.gz
gentoo-7638d9eda1b084e4e42279a2d71efcad76b59f2b.tar.bz2
gentoo-7638d9eda1b084e4e42279a2d71efcad76b59f2b.zip
app-emulation/protontricks: add 1.7.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.7.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 70e2fc268254..07d2be25f81c 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,2 +1,3 @@
DIST protontricks-1.6.0.tar.gz 61220 BLAKE2B 8a9af6f8cc134ad0e74b4c5e6c35bc8344687e65cc9811ca54402b16f723264cef8def6e733a532fd412db51d0ec63533baec52699ae994a97ecad0a25ebe847 SHA512 7276d7de1f0c18afc5c67552290888e3851bd5f073bbbf684000be66c2e65abac84b079373b120ff0ab6e4f4919caf8ee1288a2320de6c37629cb1185dfbea29
DIST protontricks-1.6.2.tar.gz 137643 BLAKE2B 09e6c37291eb47224d8f7cfcb5e864c86f6ea7ddcbbd11d1d64fbd24b2eed35aacfacad72e8481d7a3c76a915727e7dd8a58e80af9d208892a434dafb4098c17 SHA512 d0acf685c0f4480360bdf9c4e6444d51262316710d1dc6b0ca612da26a56efca647e9cdc030639bcaaa929077062cfa04a024b657a9456677d751758fe7d8552
+DIST protontricks-1.7.0.tar.gz 139203 BLAKE2B d93bbb672286d32743da1473e132508084bae527159911367c51e88686c38d3bad0a2f72a2c0f0feb09412e31e6d5bb20dfe113b9e71e4e655693bfbe663a968 SHA512 c12f211051bc23c8eb03c5385e8245361d72dcce1e641a7da1f87f344db5fdc7d698bd7691e0855ae025c1d94944db89b380805664d87123b6252d06259480ff
diff --git a/app-emulation/protontricks/protontricks-1.7.0.ebuild b/app-emulation/protontricks/protontricks-1.7.0.ebuild
new file mode 100644
index 000000000000..cfb253df8379
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}