summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-08-17 13:08:47 +0100
committerMarek Szuba <marecki@gentoo.org>2021-08-17 13:10:02 +0100
commit8708a0b9e25fe0d5693497e9b9188bd70dcd69e2 (patch)
tree7c9eee6d79a9f54597c49d5fc758a49f0a557237 /app-emulation/protontricks
parentdev-python/sphinx_ansible_theme: add 0.8.0 (diff)
downloadgentoo-8708a0b9e25fe0d5693497e9b9188bd70dcd69e2.tar.gz
gentoo-8708a0b9e25fe0d5693497e9b9188bd70dcd69e2.tar.bz2
gentoo-8708a0b9e25fe0d5693497e9b9188bd70dcd69e2.zip
app-emulation/protontricks: add 1.6.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.6.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 333044bea96b..e91938f98fd5 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1 +1,2 @@
DIST protontricks-1.5.2.tar.gz 49590 BLAKE2B 9a4f6b5869d2d23d104c3785a99549e74168d7dea429bed78ed00029ed6431460bab2c8fdd4f3905943b3e93075dea4bc9b0bf472f0044e5cbae3c335d128c12 SHA512 9e57c7ea61ae9a6638ee967041672a85962c9210fe329600bf30ab78f46b2a23cc6f859fb78e50e94686794b3fad81185d83222ca8f67e1dc73b578df7dcd411
+DIST protontricks-1.6.0.tar.gz 61220 BLAKE2B 8a9af6f8cc134ad0e74b4c5e6c35bc8344687e65cc9811ca54402b16f723264cef8def6e733a532fd412db51d0ec63533baec52699ae994a97ecad0a25ebe847 SHA512 7276d7de1f0c18afc5c67552290888e3851bd5f073bbbf684000be66c2e65abac84b079373b120ff0ab6e4f4919caf8ee1288a2320de6c37629cb1185dfbea29
diff --git a/app-emulation/protontricks/protontricks-1.6.0.ebuild b/app-emulation/protontricks/protontricks-1.6.0.ebuild
new file mode 100644
index 000000000000..11287d6d76bf
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="https://github.com/Matoking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0_no-setuptools-scm.patch
+)
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}