summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-30 11:17:28 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-30 11:42:31 +0100
commitc84040c5c23a153b03049fba3fbc88768ff244a0 (patch)
treeafa138d396b94c6b306a04829ddc833395a2791d /app-emulation/protontricks
parentdev-cpp/prometheus-cpp: add 1.0.1 (diff)
downloadgentoo-c84040c5c23a153b03049fba3fbc88768ff244a0.tar.gz
gentoo-c84040c5c23a153b03049fba3fbc88768ff244a0.tar.bz2
gentoo-c84040c5c23a153b03049fba3fbc88768ff244a0.zip
app-emulation/protontricks: add 1.8.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.8.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index e4fa2e2737ab..e7d925fd01a7 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,2 +1,3 @@
DIST protontricks-1.7.0.tar.gz 139203 BLAKE2B d93bbb672286d32743da1473e132508084bae527159911367c51e88686c38d3bad0a2f72a2c0f0feb09412e31e6d5bb20dfe113b9e71e4e655693bfbe663a968 SHA512 c12f211051bc23c8eb03c5385e8245361d72dcce1e641a7da1f87f344db5fdc7d698bd7691e0855ae025c1d94944db89b380805664d87123b6252d06259480ff
DIST protontricks-1.8.1.tar.gz 151972 BLAKE2B 1e7b600bfc22c46e879c5684229e374699548bc96d172c23d4b3c7c08871c0baf629436e81ad35d0d5e93e11515c8a20d4365658d10610cd60b04d6982b83b7c SHA512 246e65f61ef4fd6825e426aa2b4ed3df26ad1443fabca079194890a8115805ff2f51be96ce410854407b61451dafbec6abd1e26f029c1e442af10a209c75377a
+DIST protontricks-1.8.2.tar.gz 153142 BLAKE2B c0757973f7e1c442ab0bba27c2c739a7b24d45bab31ec308ec195290e35392d222369dbfe64f558e21ed1b61d13bdae629c0ba8b2f81b9af2b4f2f94c30ba9ea SHA512 9b83c34847e8ea8ae86f77330f626748a8ef5682c99619d90fea0c52de3ccd5b4285e5dfc676b8c046b9deec996847dbb0586596428507e162e255a852b28cd1
diff --git a/app-emulation/protontricks/protontricks-1.8.2.ebuild b/app-emulation/protontricks/protontricks-1.8.2.ebuild
new file mode 100644
index 000000000000..d33c17e8e46a
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.8.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}