summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-12-19 15:15:33 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-12-19 15:46:42 -0600
commit725fa92b24a3b3c8b8843eeb90e8115c0e9706f5 (patch)
tree156ed33c7644f2574ab88cefa706fdb742cfc364 /app-emulation/qemu/qemu-9999.ebuild
parentapp-emulation/qemu: version bump to 3.1.0 (diff)
downloadgentoo-725fa92b24a3b3c8b8843eeb90e8115c0e9706f5.tar.gz
gentoo-725fa92b24a3b3c8b8843eeb90e8115c0e9706f5.tar.bz2
gentoo-725fa92b24a3b3c8b8843eeb90e8115c0e9706f5.zip
app-emulation/qemu: synchronize 3.1.0 and 9999 ebuilds
- update to EAPI=7 - drop versionator inherit Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/qemu/qemu-9999.ebuild')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index b279da622c3d..8d6db73b9c7b 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
PYTHON_REQ_USE="ncurses,readline"
@@ -11,14 +11,14 @@ PLOCALES="bg de_DE fr_FR hu it tr zh_CN"
FIRMWARE_ABI_VERSION="2.11.1-r50"
inherit eutils flag-o-matic linux-info toolchain-funcs multilib python-r1 \
- user udev fcaps readme.gentoo-r1 pax-utils l10n versionator
+ user udev fcaps readme.gentoo-r1 pax-utils l10n
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://git.qemu.org/qemu.git"
inherit git-r3
SRC_URI=""
else
- SRC_URI="http://wiki.qemu-project.org/download/${P}.tar.bz2"
+ SRC_URI="http://wiki.qemu-project.org/download/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
fi
@@ -27,13 +27,15 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
-IUSE="accessibility +aio alsa bluetooth bzip2 capstone +caps +curl debug
+IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug
+fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
pulseaudio python rbd sasl +seccomp sdl selinux smartcard snappy
spice ssh static static-user systemtap tci test usb usbredir vde
+vhost-net virgl virtfs +vnc vte xattr xen xfs"
+RESTRICT=strip
+
COMMON_TARGETS="aarch64 alpha arm cris hppa i386 m68k microblaze microblazeel
mips mips64 mips64el mipsel nios2 or1k ppc ppc64 riscv32 riscv64 s390x
sh4 sh4eb sparc sparc64 x86_64 xtensa xtensaeb"
@@ -53,9 +55,11 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
qemu_softmmu_targets_arm? ( fdt )
qemu_softmmu_targets_microblaze? ( fdt )
qemu_softmmu_targets_mips64el? ( fdt )
- qemu_softmmu_targets_ppc? ( fdt )
qemu_softmmu_targets_ppc64? ( fdt )
- static? ( static-user !alsa !bluetooth !gtk !opengl !pulseaudio !snappy )
+ qemu_softmmu_targets_ppc? ( fdt )
+ qemu_softmmu_targets_riscv32? ( fdt )
+ qemu_softmmu_targets_riscv64? ( fdt )
+ static? ( static-user !alsa !gtk !opengl !pulseaudio !snappy )
virtfs? ( xattr )
vte? ( gtk )"
@@ -86,7 +90,6 @@ SOFTMMU_TOOLS_DEPEND="
)
aio? ( dev-libs/libaio[static-libs(+)] )
alsa? ( >=media-libs/alsa-lib-1.0.13 )
- bluetooth? ( net-wireless/bluez )
bzip2? ( app-arch/bzip2[static-libs(+)] )
capstone? ( dev-libs/capstone )
caps? ( sys-libs/libcap-ng[static-libs(+)] )
@@ -202,8 +205,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.11.1-capstone_include_path.patch
)
-STRIP_MASK="/usr/share/qemu/palcode-clipper"
-
QA_PREBUILT="
usr/share/qemu/hppa-firmware.img
usr/share/qemu/openbios-ppc
@@ -423,10 +424,10 @@ qemu_src_configure() {
fi
}
conf_opts+=(
+ --disable-bluez
$(conf_notuser accessibility brlapi)
$(conf_notuser aio linux-aio)
$(conf_notuser bzip2)
- $(conf_notuser bluetooth bluez)
$(conf_notuser capstone)
$(conf_notuser caps cap-ng)
$(conf_notuser curl)