summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-05-19 16:45:31 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-05-19 18:42:10 -0500
commit6577e1d2bf56e0954eb0058e51e0b93a878d3323 (patch)
tree00498f47611aa453fb0b6849fc34742c85fef29a /app-emulation/qemu
parentapp-eselect/eselect-sh: add ~arm64 keyword (diff)
downloadgentoo-6577e1d2bf56e0954eb0058e51e0b93a878d3323.tar.gz
gentoo-6577e1d2bf56e0954eb0058e51e0b93a878d3323.tar.bz2
gentoo-6577e1d2bf56e0954eb0058e51e0b93a878d3323.zip
app-emulation/qemu: introduce USE=doc
Closes: https://bugs.gentoo.org/684792 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-4.0.0-r3.ebuild (renamed from app-emulation/qemu/qemu-4.0.0-r2.ebuild)6
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild5
2 files changed, 6 insertions, 5 deletions
diff --git a/app-emulation/qemu/qemu-4.0.0-r2.ebuild b/app-emulation/qemu/qemu-4.0.0-r3.ebuild
index 338b4117ba2a..f513f3877479 100644
--- a/app-emulation/qemu/qemu-4.0.0-r2.ebuild
+++ b/app-emulation/qemu/qemu-4.0.0-r3.ebuild
@@ -27,7 +27,7 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
-IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug
+IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug +doc
+fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
pulseaudio python rbd sasl +seccomp sdl selinux smartcard snappy
@@ -171,9 +171,9 @@ PPC64_FIRMWARE_DEPEND="
BDEPEND="
${PYTHON_DEPS}
dev-lang/perl
- dev-python/sphinx
sys-apps/texinfo
virtual/pkgconfig
+ doc? ( dev-python/sphinx )
gtk? ( nls? ( sys-devel/gettext ) )
test? (
dev-libs/glib[utils]
@@ -407,7 +407,7 @@ qemu_src_configure() {
--host-cc="$(tc-getBUILD_CC)"
$(use_enable debug debug-info)
$(use_enable debug debug-tcg)
- --enable-docs
+ $(use_enable doc docs)
$(use_enable tci tcg-interpreter)
$(use_enable xattr attr)
)
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index e765af785c68..c67b7be03874 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -27,7 +27,7 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
-IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug
+IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug +doc
+fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
pulseaudio python rbd sasl +seccomp sdl selinux smartcard snappy
@@ -174,6 +174,7 @@ BDEPEND="
dev-python/sphinx
sys-apps/texinfo
virtual/pkgconfig
+ doc? ( dev-python/sphinx )
gtk? ( nls? ( sys-devel/gettext ) )
test? (
dev-libs/glib[utils]
@@ -405,7 +406,7 @@ qemu_src_configure() {
--host-cc="$(tc-getBUILD_CC)"
$(use_enable debug debug-info)
$(use_enable debug debug-tcg)
- --enable-docs
+ $(use_enable doc docs)
$(use_enable tci tcg-interpreter)
$(use_enable xattr attr)
)