summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-02-21 21:52:06 -0800
committerZac Medico <zmedico@gentoo.org>2016-02-21 21:55:20 -0800
commitbf26f36f5a139d74f3588e8867280ec947c7fb93 (patch)
treec72fc94e9a202b55c7de84c1aba831a956d42133 /app-emulation/rkt
parentdev-util/debootstrap: Old. (diff)
downloadgentoo-bf26f36f5a139d74f3588e8867280ec947c7fb93.tar.gz
gentoo-bf26f36f5a139d74f3588e8867280ec947c7fb93.tar.bz2
gentoo-bf26f36f5a139d74f3588e8867280ec947c7fb93.zip
app-emulation/rkt: version bump to 1.0.0
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-emulation/rkt')
-rw-r--r--app-emulation/rkt/Manifest2
-rw-r--r--app-emulation/rkt/metadata.xml5
-rw-r--r--app-emulation/rkt/rkt-1.0.0.ebuild103
3 files changed, 110 insertions, 0 deletions
diff --git a/app-emulation/rkt/Manifest b/app-emulation/rkt/Manifest
index d74b026c6ca6..3da236a5088f 100644
--- a/app-emulation/rkt/Manifest
+++ b/app-emulation/rkt/Manifest
@@ -1,2 +1,4 @@
DIST rkt-0.8.0.tar.gz 1749853 SHA256 c9eb0126b8ff2f059d7cedaab17ca73dce256f342092c9bf4a7ae20661f2a5aa SHA512 4e2c27fb40cd3d27de062631105db3ea04ed902f48abb647a8e4de249478dd8a145ac0b77fd5b261cc680df1bcaa4067accb8a597def9b3963108e2c1f3d9d5a WHIRLPOOL f65ddd8908ec30cfefa06e60cd4d8cdb2099ab279b6350790eb3e436b88c792efe28cea53569f48d42f6eec682635a4212f16fea9d184e6baa97877a643e1106
+DIST rkt-1.0.0.tar.gz 2414183 SHA256 7e30b03fa51a34db095484c4b111c526e49bead4e33232e1b239090503d7ac97 SHA512 f176532486b68ebc15aae17cfcf31e0f97ce3afc96bfed1c4f918da41350ef21c170712cb071a8720f39ee757b7b9ba1e66730d6e12acb9753446b929801c4ff WHIRLPOOL b2fc3082693b474584292a6ec943a685826364632dc346b18233bf9b9d2feaf14981f4a7fcbd9e79b98c2466b2f24be9b57f6345c89aeea5d075cdbeee26aba5
DIST rkt-pxe-738.1.0.img 151780780 SHA256 805a4c491281553c8927f3dd1a7bec50cca29209d0a7264870e7155d794ecbe6 SHA512 7774cc64dfa874f08f48cba0c15103e9eca86ffd87dcb24f765a9b56074e72f6862a663a4007a0a7dd296740ae91bf4edf7290fa35659b0b1572fe2f5dad3256 WHIRLPOOL 5973a6036d650c576bb0bd365c8c9ea35776501c1fd2baf1d7c00d06496fab35e9c796096ef89b095e7a922e2062dce6c0d1c85cd3101022e0aca84277d18cb9
+DIST rkt-pxe-794.1.0.img 185121072 SHA256 d513e27d2412d8fdaa2456786703346f10c24a62480d2036ca5c31b3d5a0df16 SHA512 f36324e9736bb0c533706c45d4146bed2efcb3ee2cb842c3624a62399835808c0df2aef56495a12b30f67c47fd84e93e34b10c57e4aa6d0450402d5e21c6f88c WHIRLPOOL 099851022b11aa29d004bbcef316a7cceeb5efa43f8069cdf1858888e7550f938fd9f9ec53eb63c313b5c1b93b0569f578a50fc5bae28b4d30c451a2ffd2adba
diff --git a/app-emulation/rkt/metadata.xml b/app-emulation/rkt/metadata.xml
index 5616198ef171..33d47776dd7f 100644
--- a/app-emulation/rkt/metadata.xml
+++ b/app-emulation/rkt/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
<longdescription lang="en">
rkt is a new container runtime, designed for composability, security,
and speed. Today we are releasing a prototype version on GitHub to begin
@@ -10,6 +14,7 @@
<use>
<flag name="actool">Install the actool for ACI manipulation</flag>
<flag name="rkt_stage1_coreos">Download and use a prebuilt stage1.aci from CoreOS</flag>
+ <flag name="rkt_stage1_fly">Build stage1-fly.aci</flag>
<flag name="rkt_stage1_src">Build the stage1.aci from source</flag>
<flag name="rkt_stage1_host">Assemble stage1.aci from host binaries</flag>
</use>
diff --git a/app-emulation/rkt/rkt-1.0.0.ebuild b/app-emulation/rkt/rkt-1.0.0.ebuild
new file mode 100644
index 000000000000..858b0c342316
--- /dev/null
+++ b/app-emulation/rkt/rkt-1.0.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+
+inherit autotools-utils flag-o-matic systemd toolchain-funcs
+
+KEYWORDS="~amd64"
+
+PXE_VERSION="794.1.0"
+PXE_SYSTEMD_VERSION="v222"
+PXE_URI="http://alpha.release.core-os.net/amd64-usr/${PXE_VERSION}/coreos_production_pxe_image.cpio.gz"
+PXE_FILE="${PN}-pxe-${PXE_VERSION}.img"
+
+SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+rkt_stage1_coreos? ( $PXE_URI -> $PXE_FILE )"
+
+DESCRIPTION="A CLI for running app containers, and an implementation of the App
+Container Spec."
+HOMEPAGE="https://github.com/coreos/rkt"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc examples +rkt_stage1_coreos +rkt_stage1_fly +actool"
+REQUIRED_USE="|| ( rkt_stage1_coreos rkt_stage1_fly )"
+
+DEPEND=">=dev-lang/go-1.4.1
+ app-arch/cpio
+ sys-fs/squashfs-tools
+ dev-perl/Capture-Tiny"
+
+RDEPEND="!app-emulation/rocket"
+
+BUILDDIR="build-${P}"
+STAGE1_DEFAULT_LOCATION="/usr/share/rkt/stage1.aci"
+
+src_configure() {
+ local flavors myeconfargs=(
+ --with-stage1-default-images-directory="/usr/share/rkt"
+ --with-stage1-default-location="${STAGE1_DEFAULT_LOCATION}"
+ )
+
+ # TODO:
+ # - fix rkt_stage1_kvm to not download kernel sources with wget
+ # - fix rkt_stage1_src to not download systemd sources with git clone
+ # - fix rkt_stage1_host to not fail during launch
+
+ # enable flavors (first is default)
+ use rkt_stage1_coreos && flavors+=",coreos"
+ use rkt_stage1_fly && flavors+=",fly"
+ myeconfargs+=( --with-stage1-flavors="${flavors#,}" )
+
+ if use rkt_stage1_coreos; then
+ myeconfargs+=(
+ --with-coreos-local-pxe-image-path="${DISTDIR}/${PXE_FILE}"
+ --with-coreos-local-pxe-image-systemd-version="${PXE_SYSTEMD_VERSION}"
+ )
+ fi
+
+ # Go's 6l linker does not support PIE, disable so cgo binaries
+ # which use 6l+gcc for linking can be built correctly.
+ if gcc-specs-pie; then
+ append-ldflags -nopie
+ fi
+
+ export CC=$(tc-getCC)
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export BUILDDIR
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+ use actool && dobin "${S}/${BUILDDIR}/bin/actool"
+
+ dobin "${S}/${BUILDDIR}/bin/rkt"
+
+ insinto /usr/share/rkt
+ doins "${S}/${BUILDDIR}/bin/"*.aci
+
+ # create symlink for default stage1 image path
+ if use rkt_stage1_coreos; then
+ dosym stage1-coreos.aci "${STAGE1_DEFAULT_LOCATION}"
+ elif use rkt_stage1_fly; then
+ dosym stage1-fly.aci "${STAGE1_DEFAULT_LOCATION}"
+ fi
+
+ systemd_dounit "${S}"/dist/init/systemd/${PN}-gc.service
+ systemd_dounit "${S}"/dist/init/systemd/${PN}-gc.timer
+ systemd_dounit "${S}"/dist/init/systemd/${PN}-metadata.service
+ systemd_dounit "${S}"/dist/init/systemd/${PN}-metadata.socket
+}