summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2020-09-05 11:56:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-10 07:14:48 +0200
commit35f46741a6ce045a46b3761ecdd4525252ef5c3d (patch)
treea0030e80b9ab40e2112786838a7bcc1d051e7e7b /app-emulation/sen
parentdev-util/jenkins-bin: add 2.249.1 (diff)
downloadgentoo-35f46741a6ce045a46b3761ecdd4525252ef5c3d.tar.gz
gentoo-35f46741a6ce045a46b3761ecdd4525252ef5c3d.tar.bz2
gentoo-35f46741a6ce045a46b3761ecdd4525252ef5c3d.zip
app-emulation/sen: Patch bump to 0.6.1_p20200903
Bug: https://bugs.gentoo.org/718214 Package-Manager: Portage-3.0.5, Repoman-2.3.23 Signed-off-by: Nelo-T. Wallus <nelo@wallus.de> Closes: https://github.com/gentoo/gentoo/pull/17423 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-emulation/sen')
-rw-r--r--app-emulation/sen/Manifest1
-rw-r--r--app-emulation/sen/sen-0.6.1_p20200905.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/sen/Manifest b/app-emulation/sen/Manifest
index df3d6785fdc1..7618cbd5460b 100644
--- a/app-emulation/sen/Manifest
+++ b/app-emulation/sen/Manifest
@@ -1,2 +1,3 @@
DIST sen-0.6.0.tar.gz 55113 BLAKE2B 5f6affbea94005c0adc9ac544d40d94cd9a9eca930b979c19174d21d73fdd887d21802a5241c02ba212a45c4a7873f22c7372aeb69955e1f97e444ef74d91929 SHA512 5573a0d6da5ae395e947bf34c54313e4e3a0251dc1868c52bbfe9ad11463397da83a0c9ac3f1912da2e6f49341c84d40dcab900d41b4a32ebac44d1dde3ac82b
DIST sen-0.6.1.tar.gz 55357 BLAKE2B 0d58f0ea11eeff29161925018425c918b3260c754d1b658e2ebd3c88e0c371feb0f1815af61979206bee529c369a90ace895d25e645ef0d76c563abd8b74c943 SHA512 2f1cadf745ca7e12d3e92534e76984072b9678055b9911f76b1a6d3cbd43266ad1eeb4d5e7bb8742db91c4da4aef684fa644c33de6fa2494c37688e9747e0efa
+DIST sen-0.6.1_p20200905.tar.gz 1913978 BLAKE2B 189bff583770265de29ca3e54cad1283051c05eccab4fc98160801e50b31376188c52e49b43972292fe231b376ba42879fb34d7b1ae70c2246d676a6e25f670b SHA512 cd1899c1b4c5c7cf7f1f2f5e557bd609a7d7619dbc3fc6457f5ef5ce5c9ab43d92a6fbfa228c43d543d4f46c7928d74dbed9ab8346cabc772c8e7c63a7c07bfe
diff --git a/app-emulation/sen/sen-0.6.1_p20200905.ebuild b/app-emulation/sen/sen-0.6.1_p20200905.ebuild
new file mode 100644
index 000000000000..785fd0d41f7d
--- /dev/null
+++ b/app-emulation/sen/sen-0.6.1_p20200905.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+COMMIT="02e5872ee2905861e1da06ab5174e1a3f41f0e0b"
+
+DESCRIPTION="Terminal User Interface for docker engine"
+HOMEPAGE="https://github.com/TomasTomecek/sen"
+SRC_URI="https://github.com/TomasTomecek/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
+ dev-python/docker-py[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ )
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}
+
+python_test() {
+ pytest -vv tests || die "pytest failed"
+}