summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/softgun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/softgun')
-rw-r--r--app-emulation/softgun/Manifest2
-rw-r--r--app-emulation/softgun/files/softgun-0.21-make.patch68
-rw-r--r--app-emulation/softgun/files/softgun-0.22-make.patch75
-rw-r--r--app-emulation/softgun/metadata.xml8
-rw-r--r--app-emulation/softgun/softgun-0.21.ebuild33
-rw-r--r--app-emulation/softgun/softgun-0.22.ebuild33
6 files changed, 219 insertions, 0 deletions
diff --git a/app-emulation/softgun/Manifest b/app-emulation/softgun/Manifest
new file mode 100644
index 000000000000..dbb53766a0ae
--- /dev/null
+++ b/app-emulation/softgun/Manifest
@@ -0,0 +1,2 @@
+DIST softgun-0.21.tgz 1126433 SHA256 a133b6d1062545cbad78442902c9b447bc8307b08e055933fed177659b34eea5 SHA512 145c6e8407e57353212dcb7ab8193c9b5d5c7fa6271dfbe3f4637c236b07989ef61729f55850da14639dc7d7d64ad5b68c73783e634dc5d2763865977c62ca8a WHIRLPOOL a4fcaae3846ecedb863d16673630cc5b7346af010dc21fd4161b7a5a3ec8af24a1a4db018835f0b2860cc06aed4843aaba41cc47ef18a91ae5c5933e7f82be08
+DIST softgun-0.22.tgz 1239881 SHA256 413d0137a3ee588ab76703058d9bc132f25b4f760ff5a97d6150ffe2f9d2e2fb SHA512 5c13840874b09aab6c0921d705c0ea94da87cc1a80d2fcbc9f329ade25f33bb2c8eba2fe284b4c3b41e70b8f258a45fc83caa296880bfa3e7870994de587e591 WHIRLPOOL cbbb2745b9e5cf72a18fcea87c604078db436ec6376c918920f31132fdfae246fea6f9279260787e25481e43013e200e19a9b7aef05ccd469caaa84c9effb34d
diff --git a/app-emulation/softgun/files/softgun-0.21-make.patch b/app-emulation/softgun/files/softgun-0.21-make.patch
new file mode 100644
index 000000000000..bb3ded406a0a
--- /dev/null
+++ b/app-emulation/softgun/files/softgun-0.21-make.patch
@@ -0,0 +1,68 @@
+--- softgun-0.21/config.mk
++++ softgun-0.21/config.mk
+@@ -9,7 +9,7 @@ bindir=$(prefix)/bin
+ libdir=$(prefix)/lib/softgun/
+
+ #CFLAGS=-Wall -pg -O1 -g
+-CFLAGS=-Wall -O9 -g -fomit-frame-pointer -fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable
++CFLAGS+=-fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable
+ DEFS=-D_GNU_SOURCE
+ INCLUDES:=-I$(top_srcdir) -I.
+
+@@ -19,13 +19,13 @@
+ SHAREDLDFLAGS=-nostdlib -shared
+ CYGWIN=$(findstring CYGWIN,$(shell uname))
+ ifeq ($(shell uname),Linux)
+-LDFLAGS=-lpthread -lrt -lm -lz -lasound
++LDLIBS=-lpthread -ldl -lrt -lm -lz -lasound
+ else
+ ifeq ($(shell uname),FreeBSD)
+- LDFLAGS=-lpthread -lm -lz -lSDL
++ LDLIBS=-lpthread -lm -lz -lSDL
+ else
+ ifeq ($(CYGWIN),CYGWIN)
+- LDFLAGS=-lpthread -lrt -lm -lz
++ LDLIBS=-lpthread -lrt -lm -lz
+ else
+ $(error "Unknown architecture $(shell uname)")
+ endif
+--- softgun-0.21/Makefile
++++ softgun-0.21/Makefile
+@@ -116,7 +116,7 @@
+
+
+ softgun: $(OBJS)
+- $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ $(LDLIBS)
+
+ boards/libboards.a:
+ $(MAKE) -C boards libboards.a
+--- softgun-0.21/printer/module.mk
++++ softgun-0.21/printer/module.mk
+@@ -5,5 +5,5 @@
+ INSTALL_BINS += pcl3gui2png
+
+ pcl3gui2png: $(PRINTER_OBJS) printer/pcl3gui2png.c
+- $(CC) -o $@ $(PRINTER_OBJS) printer/pcl3gui2png.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+--- softgun-0.21/tools/Makefile
++++ softgun-0.21/tools/Makefile
+@@ -2,7 +2,7 @@ include ../config.mk
+
+ ifeq ($(shell uname),Linux)
+ sg_tunctl: tunctl.c
+- $(CC) $(CFLAGS) tunctl.c -o sg_tunctl
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+ install:
+ install -m 0755 sg_tunctl $(bindir)
+@@ -14,7 +14,7 @@ install:
+ endif
+
+ to_c_array: to_c_array.c
+- $(CC) $(CFLAGS) to_c_array.c -o to_c_array
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+
+ clean:
diff --git a/app-emulation/softgun/files/softgun-0.22-make.patch b/app-emulation/softgun/files/softgun-0.22-make.patch
new file mode 100644
index 000000000000..9d1ea9b38e0d
--- /dev/null
+++ b/app-emulation/softgun/files/softgun-0.22-make.patch
@@ -0,0 +1,75 @@
+--- softgun-0.22/config.mk
++++ softgun-0.22/config.mk
+@@ -9,7 +9,7 @@ bindir=$(prefix)/bin
+ libdir=$(prefix)/lib/softgun/
+
+ #CFLAGS=-Wall -pg -O0 -DPROFILE
+-CFLAGS=-Wall -O9 -g -fomit-frame-pointer -fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable
+-DEFS=-D_GNU_SOURCE
++CFLAGS+=-Wall -fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable -fno-strict-aliasing
++DEFS=$(CPPFLAGS) -D_GNU_SOURCE
+ INCLUDES:=-I$(top_srcdir) -I.
+
+@@ -17,15 +17,16 @@ INCLUDES:=-I$(top_srcdir) -I.
+ # to omit stack protection symbol in object file
+ SHAREDCFLAGS=-fPIC -nostdlib -D_SHARED_
+ SHAREDLDFLAGS=-nostdlib -shared
+-CYGWIN=$(findstring CYGWIN,$(shell uname))
+-ifeq ($(shell uname),Linux)
+-LDFLAGS=-lpthread -lrt -lm -lz -lasound
++UNAME=$(shell uname)
++CYGWIN=$(findstring CYGWIN,$(UNAME))
++ifeq ($(UNAME),Linux)
++LDLIBS=-lpthread -ldl -lrt -lm -lz -lasound
+ else
+- ifeq ($(shell uname),FreeBSD)
+- LDFLAGS=-lpthread -lm -lz -lSDL
++ ifeq ($(UNAME),FreeBSD)
++ LDLIBS=-lpthread -lm -lz -lSDL
+ else
+ ifeq ($(CYGWIN),CYGWIN)
+- LDFLAGS=-lpthread -lrt -lm -lz
++ LDLIBS=-lpthread -lrt -lm -lz
+ else
+ $(error "Unknown architecture $(shell uname)")
+ endif
+--- softgun-0.22/Makefile
++++ softgun-0.22/Makefile
+@@ -116,7 +116,7 @@
+
+
+ softgun: $(OBJS)
+- $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ $(LDLIBS)
+
+ boards/libboards.a:
+ $(MAKE) -C boards libboards.a
+--- softgun-0.22/printer/module.mk
++++ softgun-0.22/printer/module.mk
+@@ -5,5 +5,5 @@
+ INSTALL_BINS += pcl3gui2png
+
+ pcl3gui2png: $(PRINTER_OBJS) printer/pcl3gui2png.c
+- $(CC) -o $@ $(PRINTER_OBJS) printer/pcl3gui2png.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+--- softgun-0.22/tools/Makefile
++++ softgun-0.22/tools/Makefile
+@@ -2,7 +2,7 @@ include ../config.mk
+
+ ifeq ($(shell uname),Linux)
+ sg_tunctl: tunctl.c
+- $(CC) $(CFLAGS) tunctl.c -o sg_tunctl
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+ install:
+ install -m 0755 sg_tunctl $(bindir)
+@@ -14,7 +14,7 @@ install:
+ endif
+
+ to_c_array: to_c_array.c
+- $(CC) $(CFLAGS) to_c_array.c -o to_c_array
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+
+ clean:
diff --git a/app-emulation/softgun/metadata.xml b/app-emulation/softgun/metadata.xml
new file mode 100644
index 000000000000..3e94ca34282f
--- /dev/null
+++ b/app-emulation/softgun/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>arm</herd>
+ <upstream>
+ <remote-id type="sourceforge">softgun</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/softgun/softgun-0.21.ebuild b/app-emulation/softgun/softgun-0.21.ebuild
new file mode 100644
index 000000000000..16e6be2b0b79
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.21.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.21-make.patch
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-Werror:${CFLAGS}:" \
+ config.mk || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install prefix="${D}/usr"
+ dodoc README configs/*.sg
+}
diff --git a/app-emulation/softgun/softgun-0.22.ebuild b/app-emulation/softgun/softgun-0.22.ebuild
new file mode 100644
index 000000000000..a87216dcd5bf
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/alsa-lib"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.22-make.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install prefix="${D}/usr"
+ dodoc README configs/*.sg
+}