summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-03-28 20:35:01 +0200
committerPacho Ramos <pacho@gentoo.org>2018-03-28 20:35:01 +0200
commit2d4843bd31a8d55d4594e8d167226d35c4c34cfd (patch)
treeadbfcc31f678d359281c46207dd564c9e21570bf /app-emulation/vice/files
parentapp-emulation/vice: amd64 stable, bug #648890 (diff)
downloadgentoo-2d4843bd31a8d55d4594e8d167226d35c4c34cfd.tar.gz
gentoo-2d4843bd31a8d55d4594e8d167226d35c4c34cfd.tar.bz2
gentoo-2d4843bd31a8d55d4594e8d167226d35c4c34cfd.zip
app-emulation/vice: Drop old
Package-Manager: Portage-2.3.26, Repoman-2.3.7
Diffstat (limited to 'app-emulation/vice/files')
-rw-r--r--app-emulation/vice/files/vice-2.4.22-autotools.patch11
-rw-r--r--app-emulation/vice/files/vice-2.4.27-autotools.patch11
-rw-r--r--app-emulation/vice/files/vice-31580-ffmpeg-build.patch64
3 files changed, 0 insertions, 86 deletions
diff --git a/app-emulation/vice/files/vice-2.4.22-autotools.patch b/app-emulation/vice/files/vice-2.4.22-autotools.patch
deleted file mode 100644
index 7bebd2800ef6..000000000000
--- a/app-emulation/vice/files/vice-2.4.22-autotools.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- vice-2.4.7.orig/configure.ac
-+++ vice-2.4.7/configure.ac
-@@ -124,7 +118,7 @@
- AC_SUBST(VICE_VERSION)
-
- AM_INIT_AUTOMAKE(vice, $VICE_VERSION)
--AM_CONFIG_HEADER(src/config.h)
-+AC_CONFIG_HEADERS(src/config.h)
-
- if test x"$VICE_VERSION_BUILD" = "x" -o x"$VICE_VERSION_BUILD" = "x0" ; then
- VERSION_RC=$VICE_VERSION_MAJOR","$VICE_VERSION_MINOR",0,0"
diff --git a/app-emulation/vice/files/vice-2.4.27-autotools.patch b/app-emulation/vice/files/vice-2.4.27-autotools.patch
deleted file mode 100644
index 7bebd2800ef6..000000000000
--- a/app-emulation/vice/files/vice-2.4.27-autotools.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- vice-2.4.7.orig/configure.ac
-+++ vice-2.4.7/configure.ac
-@@ -124,7 +118,7 @@
- AC_SUBST(VICE_VERSION)
-
- AM_INIT_AUTOMAKE(vice, $VICE_VERSION)
--AM_CONFIG_HEADER(src/config.h)
-+AC_CONFIG_HEADERS(src/config.h)
-
- if test x"$VICE_VERSION_BUILD" = "x" -o x"$VICE_VERSION_BUILD" = "x0" ; then
- VERSION_RC=$VICE_VERSION_MAJOR","$VICE_VERSION_MINOR",0,0"
diff --git a/app-emulation/vice/files/vice-31580-ffmpeg-build.patch b/app-emulation/vice/files/vice-31580-ffmpeg-build.patch
deleted file mode 100644
index 82dc3421218a..000000000000
--- a/app-emulation/vice/files/vice-31580-ffmpeg-build.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-# Patch to fix compiling with ffmpeg-3.
-# Backported from: https://sourceforge.net/p/vice-emu/code/31580/
-
---- /src/gfxoutputdrv/ffmpeglib.h
-+++ /src/gfxoutputdrv/ffmpeglib.h
-@@ -76,6 +76,14 @@
- #define AVCodecID CodecID
- #endif
-
-+#if LIBAVUTIL_VERSION_INT < AV_VERSION_INT(55,17,103)
-+#define VICE_AV_PIX_FMT_RGB24 PIX_FMT_RGB24
-+#define VICE_AV_PixelFormat PixelFormat
-+#else
-+#define VICE_AV_PIX_FMT_RGB24 AV_PIX_FMT_RGB24
-+#define VICE_AV_PixelFormat AVPixelFormat
-+#endif
-+
- /* avcodec fucntions */
- typedef void(*av_init_packet_t)(AVPacket *pkt);
- typedef int(*avcodec_open2_t)(AVCodecContext*, AVCodec*, AVDictionary **);
-@@ -118,7 +126,7 @@
-
- /* swscale functions */
- typedef struct SwsContext * (*sws_getContext_t)(int srcW, int srcH,
-- enum PixelFormat srcFormat, int dstW, int dstH, enum PixelFormat dstFormat,
-+ enum VICE_AV_PixelFormat srcFormat, int dstW, int dstH, enum VICE_AV_PixelFormat dstFormat,
- int flags, SwsFilter *srcFilter, SwsFilter *dstFilter, double *param);
- typedef void (*sws_freeContext_t)(struct SwsContext *swsContext);
- typedef int (*sws_scale_t)(struct SwsContext *context, uint8_t* srcSlice[],
-
---- /src/gfxoutputdrv/ffmpegdrv.c
-+++ /src/gfxoutputdrv/ffmpegdrv.c
-@@ -671,8 +671,8 @@
- picture is needed too. It is then converted to the required
- output format */
- video_st.tmp_frame = NULL;
-- if (c->pix_fmt != PIX_FMT_RGB24) {
-- video_st.tmp_frame = ffmpegdrv_alloc_picture(PIX_FMT_RGB24, c->width, c->height);
-+ if (c->pix_fmt != VICE_AV_PIX_FMT_RGB24) {
-+ video_st.tmp_frame = ffmpegdrv_alloc_picture(VICE_AV_PIX_FMT_RGB24, c->width, c->height);
- if (!video_st.tmp_frame) {
- log_debug("ffmpegdrv: could not allocate temporary picture");
- return -1;
-@@ -769,9 +769,9 @@
-
- #ifdef HAVE_FFMPEG_SWSCALE
- /* setup scaler */
-- if (c->pix_fmt != PIX_FMT_RGB24) {
-+ if (c->pix_fmt != VICE_AV_PIX_FMT_RGB24) {
- sws_ctx = VICE_P_SWS_GETCONTEXT
-- (video_width, video_height, PIX_FMT_RGB24,
-+ (video_width, video_height, VICE_AV_PIX_FMT_RGB24,
- video_width, video_height, c->pix_fmt,
- SWS_BICUBIC,
- NULL, NULL, NULL);
-@@ -948,7 +948,7 @@
-
- c = video_st.st->codec;
-
-- if (c->pix_fmt != PIX_FMT_RGB24) {
-+ if (c->pix_fmt != VICE_AV_PIX_FMT_RGB24) {
- ffmpegdrv_fill_rgb_image(screenshot, video_st.tmp_frame);
-
- if (sws_ctx != NULL) {