summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-07-01 12:08:51 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-07-01 12:08:51 -0500
commit5de19cf299586e09e0369934b32afd90021e9292 (patch)
tree8695b1e5a49793c9a7747a79aedaa028b5a23e5b /app-emulation/virt-viewer/virt-viewer-8.0.ebuild
parentapp-emulation/virt-manager: revert xdg changes (diff)
downloadgentoo-5de19cf299586e09e0369934b32afd90021e9292.tar.gz
gentoo-5de19cf299586e09e0369934b32afd90021e9292.tar.bz2
gentoo-5de19cf299586e09e0369934b32afd90021e9292.zip
app-emulation/virt-viewer: version bump to 8.0
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/virt-viewer/virt-viewer-8.0.ebuild')
-rw-r--r--app-emulation/virt-viewer/virt-viewer-8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/virt-viewer/virt-viewer-8.0.ebuild b/app-emulation/virt-viewer/virt-viewer-8.0.ebuild
new file mode 100644
index 000000000000..bff9034cfbdb
--- /dev/null
+++ b/app-emulation/virt-viewer/virt-viewer-8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Graphical console client for connecting to virtual machines"
+HOMEPAGE="http://virt-manager.org/"
+SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl +spice +vnc"
+
+RDEPEND=">=app-emulation/libvirt-0.10.0[sasl?]
+ app-emulation/libvirt-glib
+ >=dev-libs/libxml2-2.6
+ x11-libs/gtk+:3
+ spice? ( >=net-misc/spice-gtk-0.35[sasl?,gtk3] )
+ vnc? ( >=net-libs/gtk-vnc-0.5.0[sasl?,gtk3(+)] )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ spice? ( >=app-emulation/spice-protocol-0.12.10 )"
+
+REQUIRED_USE="|| ( spice vnc )"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-update-mimedb \
+ --without-ovirt \
+ $(use_with vnc gtk-vnc) \
+ $(use_with spice spice-gtk)
+}