summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-13 22:10:48 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-13 22:21:58 -0400
commit4a814d75f9321004b29d64e9e2a229f12cf1a041 (patch)
tree1b012658a70ea1194ab2ff76aa4f5bf35b6a0db3 /app-emulation/vkd3d-proton
parentapp-emulation/dxvk: add bypass for crossdev checks / unset (diff)
downloadgentoo-4a814d75f9321004b29d64e9e2a229f12cf1a041.tar.gz
gentoo-4a814d75f9321004b29d64e9e2a229f12cf1a041.tar.bz2
gentoo-4a814d75f9321004b29d64e9e2a229f12cf1a041.zip
app-emulation/vkd3d-proton: add bypass for crossdev checks / unset
Unset is needed given CC is not expected to be a cross-compiler but, if users know what they are doing, leave a way (MINGW_BYPASS=1). If e.g. llvm-mingw is ever officially supported, may need a mingw eclass to juggle toolchains properly and instruct about them. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/vkd3d-proton')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild6
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
index 68245c3ef796..14ead4c9f1e1 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
@@ -43,7 +43,7 @@ BDEPEND="
pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return
- if use crossdev-mingw; then
+ if use crossdev-mingw && [[ ! -v MINGW_BYPASS ]]; then
local tool=-w64-mingw32-g++
for tool in $(usev abi_x86_64 x86_64${tool}) $(usev abi_x86_32 i686${tool}); do
if ! type -P ${tool} >/dev/null; then
@@ -94,7 +94,7 @@ src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
if [[ ${CHOST} != *-mingw* ]]; then
- unset AR CC CXX STRIP WIDL # likely unusable unless CHOST is mingw
+ [[ ! -v MINGW_BYPASS ]] && unset AR CC CXX STRIP WIDL
CHOST_amd64=x86_64-w64-mingw32
CHOST_x86=i686-w64-mingw32
@@ -113,7 +113,7 @@ src_configure() {
multilib_src_configure() {
# multilib's ${CHOST_amd64}-gcc -m32 is unusable with crossdev,
# unset again so meson eclass will set ${CHOST}-gcc + others
- use crossdev-mingw && unset AR CC CXX STRIP WIDL
+ use crossdev-mingw && [[ ! -v MINGW_BYPASS ]] && unset AR CC CXX STRIP WIDL
# prefer ${CHOST}'s widl (mingw) over wine's as used by upstream if
# possible, but eclasses don't handle that so setup machine files
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 68245c3ef796..14ead4c9f1e1 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -43,7 +43,7 @@ BDEPEND="
pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return
- if use crossdev-mingw; then
+ if use crossdev-mingw && [[ ! -v MINGW_BYPASS ]]; then
local tool=-w64-mingw32-g++
for tool in $(usev abi_x86_64 x86_64${tool}) $(usev abi_x86_32 i686${tool}); do
if ! type -P ${tool} >/dev/null; then
@@ -94,7 +94,7 @@ src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
if [[ ${CHOST} != *-mingw* ]]; then
- unset AR CC CXX STRIP WIDL # likely unusable unless CHOST is mingw
+ [[ ! -v MINGW_BYPASS ]] && unset AR CC CXX STRIP WIDL
CHOST_amd64=x86_64-w64-mingw32
CHOST_x86=i686-w64-mingw32
@@ -113,7 +113,7 @@ src_configure() {
multilib_src_configure() {
# multilib's ${CHOST_amd64}-gcc -m32 is unusable with crossdev,
# unset again so meson eclass will set ${CHOST}-gcc + others
- use crossdev-mingw && unset AR CC CXX STRIP WIDL
+ use crossdev-mingw && [[ ! -v MINGW_BYPASS ]] && unset AR CC CXX STRIP WIDL
# prefer ${CHOST}'s widl (mingw) over wine's as used by upstream if
# possible, but eclasses don't handle that so setup machine files