summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-07-16 11:41:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-07-16 12:56:35 -0400
commitd327f1dd4369a20c5ad4baca54d87b7faabbbfc8 (patch)
treebb9428aa3729123cd54079a3c238e9ca71260ffe /app-emulation/vkd3d-proton
parentapp-emulation/dxvk: filter -fuse-ld for mingw (diff)
downloadgentoo-d327f1dd4369a20c5ad4baca54d87b7faabbbfc8.tar.gz
gentoo-d327f1dd4369a20c5ad4baca54d87b7faabbbfc8.tar.bz2
gentoo-d327f1dd4369a20c5ad4baca54d87b7faabbbfc8.zip
app-emulation/vkd3d-proton: filter -fuse-ld for mingw
flag-o-matic is looking at respecting -fuse-ld for test-flags-CCLD, which is good but don't want this when doing the user-unexpected switch to mingw toolchain (filtering feels more solid either way). Users can use MINGW_BYPASS=1 if really need full control. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/vkd3d-proton')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild5
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
index 664241e57d2e..237c309402ea 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
@@ -94,7 +94,10 @@ src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
if [[ ${CHOST} != *-mingw* ]]; then
- [[ ! -v MINGW_BYPASS ]] && unset AR CC CXX STRIP WIDL
+ if [[ ! -v MINGW_BYPASS ]]; then
+ unset AR CC CXX RC STRIP WIDL
+ filter-flags '-fuse-ld=*'
+ fi
CHOST_amd64=x86_64-w64-mingw32
CHOST_x86=i686-w64-mingw32
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 664241e57d2e..237c309402ea 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -94,7 +94,10 @@ src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
if [[ ${CHOST} != *-mingw* ]]; then
- [[ ! -v MINGW_BYPASS ]] && unset AR CC CXX STRIP WIDL
+ if [[ ! -v MINGW_BYPASS ]]; then
+ unset AR CC CXX RC STRIP WIDL
+ filter-flags '-fuse-ld=*'
+ fi
CHOST_amd64=x86_64-w64-mingw32
CHOST_x86=i686-w64-mingw32