summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2019-08-19 18:47:16 -0400
committerNick Sarnie <sarnex@gentoo.org>2019-08-19 18:47:16 -0400
commit1ec6d6809fdcd73bb93f8c5c0aeae1a48b43775b (patch)
treec92e0521006f3a54dd6351d9aa50bd5c46659b40 /app-emulation/wine-staging/wine-staging-9999.ebuild
parentapp-emulation/wine-vanilla: Sync with ::wine (diff)
downloadgentoo-1ec6d6809fdcd73bb93f8c5c0aeae1a48b43775b.tar.gz
gentoo-1ec6d6809fdcd73bb93f8c5c0aeae1a48b43775b.tar.bz2
gentoo-1ec6d6809fdcd73bb93f8c5c0aeae1a48b43775b.zip
app-emulation/wine-staging: Sync with ::wine
Port bugfix Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-9999.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index c8cbce356e29..52c20dca7b4a 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -435,7 +435,7 @@ multilib_src_configure() {
--libexecdir="${MY_LIBEXECDIR}"
--localstatedir="${MY_LOCALSTATEDIR}"
--mandir="${MY_MANDIR}"
- --sysconfdir=/etc/wine
+ --sysconfdir="${EPREFIX}/etc/wine"
$(use_with alsa)
$(use_with capi)
$(use_with lcms cms)
@@ -555,6 +555,9 @@ multilib_src_install_all() {
use abi_x86_32 && pax-mark psmr "${D%/}${MY_PREFIX}"/bin/wine{,-preloader} #255055
use abi_x86_64 && pax-mark psmr "${D%/}${MY_PREFIX}"/bin/wine64{,-preloader}
+ # Avoid double prefix from dosym and make_wrapper
+ MY_PREFIX=${MY_PREFIX#${EPREFIX}}
+
if use abi_x86_64 && ! use abi_x86_32; then
dosym wine64 "${MY_PREFIX}"/bin/wine # 404331
dosym wine64-preloader "${MY_PREFIX}"/bin/wine-preloader
@@ -565,7 +568,7 @@ multilib_src_install_all() {
# Make wrappers for binaries for handling multiple variants
# Note: wrappers instead of symlinks because some are shell which use basename
local b
- for b in "${D%/}${MY_PREFIX}"/bin/*; do
+ for b in "${ED%/}${MY_PREFIX}"/bin/*; do
make_wrapper "${b##*/}-${WINE_VARIANT}" "${MY_PREFIX}/bin/${b##*/}"
done
eshopts_pop