summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2018-01-20 02:21:27 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2018-01-20 03:00:22 -0500
commitbd36424f617fe2e10fdaa6c7b24b1ba138489c7c (patch)
tree620158936422c1328bd19e586e1e90af05ee2d45 /app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
parentdev-lang/perl: Bump 5.28.9999 to 5.27.8 (diff)
downloadgentoo-bd36424f617fe2e10fdaa6c7b24b1ba138489c7c.tar.gz
gentoo-bd36424f617fe2e10fdaa6c7b24b1ba138489c7c.tar.bz2
gentoo-bd36424f617fe2e10fdaa6c7b24b1ba138489c7c.zip
app-emulation/wine-vanilla: Sync from ::wine
Add 2.0.4, 2.21, 2.22. 3.0 Fix manpage generation Closes: https://bugs.gentoo.org/617864 Closes: https://bugs.gentoo.org/643962 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-9999.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild38
1 files changed, 28 insertions, 10 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 4e3940a00299..d1fca61ea408 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -24,7 +24,7 @@ else
fi
S="${WORKDIR}/${MY_P}"
-GWP_V="20170830"
+GWP_V="20180119"
PATCHDIR="${WORKDIR}/gentoo-wine-patches"
DESCRIPTION="Free implementation of Windows(tm) on Unix, without external patchsets"
@@ -156,7 +156,8 @@ PATCHES=(
"${PATCHDIR}/patches/${MY_PN}-1.5.26-winegcc.patch" #260726
"${PATCHDIR}/patches/${MY_PN}-1.9.5-multilib-portage.patch" #395615
"${PATCHDIR}/patches/${MY_PN}-1.6-memset-O3.patch" #480508
- "${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch"
+ "${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch" #310611
+ "${PATCHDIR}/patches/${MY_PN}-2.0-prevent-build-of-localized-manpages.patch" #469418 #617864
)
PATCHES_BIN=()
@@ -335,6 +336,31 @@ src_prepare() {
cp "${PATCHDIR}/files/oic_winlogo.ico" dlls/user32/resources/ || die
l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
+
+ # Fix manpage generation for locales #469418 and abi_x86_64 #617864
+ # Depends on wine-2.0-prevent-build-of-localized-manpages.patch"
+ # Duplicate manpages input for wine64
+ local man
+ for man in loader/*.man.in; do
+ cp ${man} ${man/wine/wine64} || die
+ done
+ # Add in proper manpages to Makefile
+ local search_text="wine.man.in"
+ if use abi_x86_64; then
+ sed -i "/${search_text}/i \
+ "$'\\\t'"wine64.man.in "$'\\\\' loader/Makefile.in || die
+ fi
+ local l
+ for l in de fr pl; do
+ if has ${l} ${LINGUAS-${l}}; then
+ sed -i "/${search_text}/i \
+ "$'\\\t'"wine.${l}.UTF-8.man.in "$'\\\\' loader/Makefile.in || die
+ if use abi_x86_64; then
+ sed -i "/${search_text}/i \
+ "$'\\\t'"wine64.${l}.UTF-8.man.in "$'\\\\' loader/Makefile.in || die
+ fi
+ fi
+ done
}
src_configure() {
@@ -479,14 +505,6 @@ multilib_src_install_all() {
for b in "${D%/}${MY_PREFIX}"/bin/*; do
make_wrapper "${b##*/}-${WINE_VARIANT}" "${MY_PREFIX}/bin/${b##*/}"
done
-
- # respect LINGUAS when installing man pages, #469418
- local l
- for l in de fr pl; do
- has ${l} ${LINGUAS-${l}} || rm -rf "${D%/}${MY_MANDIR}"/${l}*
- done
-
- eval "${glob_state}"
}
pkg_postinst() {