summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-10-03 01:40:26 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-10-03 01:41:22 -0400
commit28604e0c07a3062664926465c294038a9dcdb82f (patch)
tree76fb6ad00342f99f10fa1fa9d2039a83f06e4ca2 /app-emulation/wine/wine-1.7.51.ebuild
parentdev-ruby/http: version bump (diff)
downloadgentoo-28604e0c07a3062664926465c294038a9dcdb82f.tar.gz
gentoo-28604e0c07a3062664926465c294038a9dcdb82f.tar.bz2
gentoo-28604e0c07a3062664926465c294038a9dcdb82f.zip
app-emulation/wine: works with gcc-5.2.0 with latest patchset
Instead of a simple version check, run the upstream test case to check whether the installed gcc ebuild has the ms_abi bug or not. Gentoo-Bug: 549768 Package-Manager: portage-2.2.22
Diffstat (limited to 'app-emulation/wine/wine-1.7.51.ebuild')
-rw-r--r--app-emulation/wine/wine-1.7.51.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/app-emulation/wine/wine-1.7.51.ebuild b/app-emulation/wine/wine-1.7.51.ebuild
index d78c249d5b5e..8a8d5c1cfe01 100644
--- a/app-emulation/wine/wine-1.7.51.ebuild
+++ b/app-emulation/wine/wine-1.7.51.ebuild
@@ -166,12 +166,18 @@ wine_build_environment_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
# bug #549768
- if use abi_x86_64 && [[ $(gcc-major-version) = 5 ]]; then
- eerror "64-bit wine cannot be built with gcc-5.1 or 5.2 due to compiler bugs;"
- eerror "you may use gcc-config to select an older compiler version."
- eerror "See https://bugs.gentoo.org/549768"
- eerror
- return 1
+ if use abi_x86_64 && [[ $(gcc-major-version) = 5 && $(gcc-minor-version) -le 2 ]]; then
+ einfo "Checking for gcc-5 ms_abi compiler bug ..."
+ $(tc-getCC) -O2 "${FILESDIR}"/pr66838.c -o "${T}"/pr66838 || die
+ # Run in subshell to prevent "Aborted" message
+ if ! ( "${T}"/pr66838 || false ) >/dev/null 2>&1; then
+ eerror "64-bit wine cannot be built with gcc-5.1 or initial patchset of 5.2.0"
+ eerror "due to compiler bugs; please re-emerge the latest gcc-5.2.x ebuild,"
+ eerror "or use gcc-config to select a different compiler version."
+ eerror "See https://bugs.gentoo.org/549768"
+ eerror
+ return 1
+ fi
fi
if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then