summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-03-14 02:35:39 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-03-14 02:37:08 -0400
commite08eca66f56c895a137a1a7e6cf554d50084c925 (patch)
tree6370d104fcb2b3a9702b8dfd8489e283ff4ec50a /app-emulation/wine
parentapp-arch/p7zip: Remove unneeded/broken patching (diff)
downloadgentoo-e08eca66f56c895a137a1a7e6cf554d50084c925.tar.gz
gentoo-e08eca66f56c895a137a1a7e6cf554d50084c925.tar.bz2
gentoo-e08eca66f56c895a137a1a7e6cf554d50084c925.zip
app-emulation/wine: Update gcc 5.3 test case. #577306. Thanks to Bob Wya
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/files/pr69140.c13
-rw-r--r--app-emulation/wine/wine-1.9.5.ebuild5
-rw-r--r--app-emulation/wine/wine-9999.ebuild5
3 files changed, 17 insertions, 6 deletions
diff --git a/app-emulation/wine/files/pr69140.c b/app-emulation/wine/files/pr69140.c
index 2c345dd75bc5..7c9e001f3018 100644
--- a/app-emulation/wine/files/pr69140.c
+++ b/app-emulation/wine/files/pr69140.c
@@ -22,3 +22,16 @@ MD4Update (MD4_CTX *ctx, const unsigned char *buf)
MD4Transform( ctx->buf, (unsigned int *)ctx->in);
MD4Transform( ctx->buf, (unsigned int *)ctx->in);
}
+
+int
+main(void)
+{
+ MD4_CTX ctx_test =
+ {
+ { 0x67452301, 0xefcdab89, 0x98badcfe, 0x10325476 },
+ { 0, 0 }
+ };
+ unsigned char buf[64];
+
+ MD4Update(&ctx_test, (const unsigned char *) &buf);
+}
diff --git a/app-emulation/wine/wine-1.9.5.ebuild b/app-emulation/wine/wine-1.9.5.ebuild
index e7a9349996eb..509dbfe69bf8 100644
--- a/app-emulation/wine/wine-1.9.5.ebuild
+++ b/app-emulation/wine/wine-1.9.5.ebuild
@@ -176,9 +176,8 @@ wine_build_environment_check() {
# bug #574044
if use abi_x86_64 && [[ $(gcc-major-version) = 5 && $(gcc-minor-version) = 3 ]]; then
einfo "Checking for gcc-5-3 stack realignment compiler bug ..."
- $(tc-getCC) -O2 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || die
- # Run in subshell to prevent "Aborted" message
- if ! ( "${T}"/69140 || false ) >/dev/null 2>&1; then
+ # Compile in subshell to prevent "Aborted" message
+ if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
eerror "Wine cannot be built with this version of gcc-5.3"
eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
eerror "or use gcc-config to select a different compiler version."
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index b29387c9c02d..96af59e1aefe 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -176,9 +176,8 @@ wine_build_environment_check() {
# bug #574044
if use abi_x86_64 && [[ $(gcc-major-version) = 5 && $(gcc-minor-version) = 3 ]]; then
einfo "Checking for gcc-5-3 stack realignment compiler bug ..."
- $(tc-getCC) -O2 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || die
- # Run in subshell to prevent "Aborted" message
- if ! ( "${T}"/69140 || false ) >/dev/null 2>&1; then
+ # Compile in subshell to prevent "Aborted" message
+ if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
eerror "Wine cannot be built with this version of gcc-5.3"
eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
eerror "or use gcc-config to select a different compiler version."