summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2015-12-04 13:36:22 -0600
committerDoug Goldstein <cardoe@gentoo.org>2015-12-04 13:38:11 -0600
commit5e52bba8b60006a721f66527f194acae0410e4ce (patch)
tree2a54bcb66c07313e448c493a451da573253ac5a3 /app-emulation/xen
parentwww-servers/tomcat: version bump - slot 9 milestone 1 (diff)
downloadgentoo-5e52bba8b60006a721f66527f194acae0410e4ce.tar.gz
gentoo-5e52bba8b60006a721f66527f194acae0410e4ce.tar.bz2
gentoo-5e52bba8b60006a721f66527f194acae0410e4ce.zip
app-emulation/xen: fix compilation failures
A patch referenced in src_prepare() was missing so the package could not build. LDFLAGS were being passed in which caused build failures with USE=-custom-cflags. Dependency on binutils was incorrect.
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/xen-4.6.0-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/xen/xen-4.6.0-r2.ebuild b/app-emulation/xen/xen-4.6.0-r2.ebuild
index 76febbcf48dd..337751158d49 100644
--- a/app-emulation/xen/xen-4.6.0-r2.ebuild
+++ b/app-emulation/xen/xen-4.6.0-r2.ebuild
@@ -28,7 +28,8 @@ else
SRC_URI="http://bits.xensource.com/oss-xen/release/${MY_PV}/${MY_P}.tar.gz
${UPSTREAM_PATCHSET_URI}
${SECURITY_PATCHSET_URI}
- ${GENTOO_PATCHSET_URI}"
+ ${GENTOO_PATCHSET_URI}
+ https://dev.gentoo.org/~idella4/distfiles/${PN}-security-patches.tar.gz"
fi
inherit mount-boot flag-o-matic python-any-r1 toolchain-funcs eutils ${live_eclass}
@@ -41,7 +42,7 @@ IUSE="custom-cflags debug efi flask xsm"
DEPEND="${PYTHON_DEPS}
efi? ( >=sys-devel/binutils-2.22[multitarget] )
- !efi? ( >=sys-devel/binutils-2.22[-multitarget] )"
+ !efi? ( >=sys-devel/binutils-2.22 )"
RDEPEND=""
PDEPEND="~app-emulation/xen-tools-${PV}"
@@ -151,6 +152,8 @@ src_configure() {
replace-flags -O3 -O2
else
unset CFLAGS
+ unset LDFLAGS
+ unset ASFLAGS
fi
}