summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-04-21 19:22:22 +0200
committerPacho Ramos <pacho@gentoo.org>2017-04-21 19:36:14 +0200
commit01e392068b20ac747a58932e12147833e600c6e3 (patch)
tree2351e1ae25162a1f7fc161811cfc3465798bf280 /app-emulation
parentapp-emacs/pymacs: Support newer python (diff)
downloadgentoo-01e392068b20ac747a58932e12147833e600c6e3.tar.gz
gentoo-01e392068b20ac747a58932e12147833e600c6e3.tar.bz2
gentoo-01e392068b20ac747a58932e12147833e600c6e3.zip
app-emulation/spice: Support newer python
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/spice-0.13.3.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/app-emulation/spice/spice-0.13.3.ebuild b/app-emulation/spice/spice-0.13.3.ebuild
index 7730d4bf2c04..cced4ea32598 100644
--- a/app-emulation/spice/spice-0.13.3.ebuild
+++ b/app-emulation/spice/spice-0.13.3.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils python-any-r1 readme.gentoo-r1 xdg-utils
+inherit ltprune python-any-r1 readme.gentoo-r1 xdg-utils
DESCRIPTION="SPICE server"
HOMEPAGE="http://spice-space.org/"
@@ -24,14 +23,15 @@ RDEPEND="
sys-libs/zlib[static-libs(+)?]
virtual/jpeg:0=[static-libs(+)?]
>=x11-libs/pixman-0.17.7[static-libs(+)?]
- !libressl? ( dev-libs/openssl:0[static-libs(+)?] )
- libressl? ( dev-libs/libressl[static-libs(+)?] )
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)?] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)?] )
lz4? ( app-arch/lz4 )
smartcard? ( >=app-emulation/libcacard-0.1.2 )
sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
- gstreamer? ( media-libs/gstreamer:1.0 )"
-
-DEPEND="
+ gstreamer? ( media-libs/gstreamer:1.0 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
>=app-emulation/spice-protocol-0.12.12
virtual/pkgconfig
$(python_gen_any_dep '
@@ -39,7 +39,7 @@ DEPEND="
dev-python/six[${PYTHON_USEDEP}]
')
smartcard? ( app-emulation/qemu[smartcard] )
- ${RDEPEND}"
+"
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
@@ -86,3 +86,7 @@ src_install() {
use static-libs || prune_libtool_files
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}