summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-05-31 22:22:41 -0700
committerZac Medico <zmedico@gentoo.org>2019-05-31 23:07:45 -0700
commit0663f0de098247b86dd2d16f79bd89f45e3bd1b4 (patch)
tree07f4f89617460f9cc3d2d165d39d7315d7fecb8d /app-emulation
parentsci-calculators/datamash: Old (diff)
downloadgentoo-0663f0de098247b86dd2d16f79bd89f45e3bd1b4.tar.gz
gentoo-0663f0de098247b86dd2d16f79bd89f45e3bd1b4.tar.bz2
gentoo-0663f0de098247b86dd2d16f79bd89f45e3bd1b4.zip
app-emulation/conmon: add package
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/conmon/Manifest1
-rw-r--r--app-emulation/conmon/conmon-0.2.0.ebuild41
-rw-r--r--app-emulation/conmon/metadata.xml11
3 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/conmon/Manifest b/app-emulation/conmon/Manifest
new file mode 100644
index 000000000000..8b116b37d32d
--- /dev/null
+++ b/app-emulation/conmon/Manifest
@@ -0,0 +1 @@
+DIST conmon-0.2.0.tar.gz 48349 BLAKE2B f61d1750437102c3772669ac8cff75204bf6811a221212cb7127a439b57b70afacb460f4128413e242ccceb0fe44c417dcd0a7f08536f272131704f3a6cbd599 SHA512 81b6eb88a473c6b4e349e18ba48682dd15f5f1ad841d2ca6bead8b5f9b418dd20832a855a1c8d81ac77562d00cb6e5852aab4f6f4ce15f099ca63a0a3f432ec8
diff --git a/app-emulation/conmon/conmon-0.2.0.ebuild b/app-emulation/conmon/conmon-0.2.0.ebuild
new file mode 100644
index 000000000000..b529698cd21c
--- /dev/null
+++ b/app-emulation/conmon/conmon-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="systemd"
+EGIT_COMMIT="59952292a3b07ac125575024ae21956efe0ecdfb"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| pkg-config --exists libsystemd-journal | false |' \
+ -e 's| pkg-config --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="${ED}/usr" \
+ install
+ mv "${ED}/usr/libexec"/{crio,podman} || die
+ dodir /usr/bin
+ ln "${ED}/usr/"{libexec/podman,bin}/conmon || die
+ dodoc README.md
+}
diff --git a/app-emulation/conmon/metadata.xml b/app-emulation/conmon/metadata.xml
new file mode 100644
index 000000000000..15f05bae08e9
--- /dev/null
+++ b/app-emulation/conmon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/conmon</remote-id>
+ </upstream>
+</pkgmetadata>