summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-07 22:47:07 +0000
committerSam James <sam@gentoo.org>2021-06-07 22:47:30 +0000
commit12a34855e09dfadf549d46a12549f9ef36f075b1 (patch)
tree95ed02f9164a2278491c5c5af1b516ccada604f1 /app-emulation
parentx11-misc/synergy: Bump to 1.14.0.3-rc (diff)
downloadgentoo-12a34855e09dfadf549d46a12549f9ef36f075b1.tar.gz
gentoo-12a34855e09dfadf549d46a12549f9ef36f075b1.tar.bz2
gentoo-12a34855e09dfadf549d46a12549f9ef36f075b1.zip
app-emulation/libguestfs: add 1.44.1
Closes: https://bugs.gentoo.org/782079 Closes: https://bugs.gentoo.org/746335 Closes: https://bugs.gentoo.org/758353 Closes: https://bugs.gentoo.org/682256 Closes: https://bugs.gentoo.org/729674 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libguestfs/Manifest1
-rw-r--r--app-emulation/libguestfs/files/1.44/0001-Check-for-caml_alloc_initialized_string-existence-ev.patch25
-rw-r--r--app-emulation/libguestfs/libguestfs-1.44.1.ebuild202
3 files changed, 228 insertions, 0 deletions
diff --git a/app-emulation/libguestfs/Manifest b/app-emulation/libguestfs/Manifest
index 7a223e5b5881..570f31abafff 100644
--- a/app-emulation/libguestfs/Manifest
+++ b/app-emulation/libguestfs/Manifest
@@ -1 +1,2 @@
DIST libguestfs-1.38.6.tar.gz 23284845 BLAKE2B 005aaef731e1711dc5f4552dbecff80f2c7a79fd8a13f6b79675b0a381dcd7b9ad16867ed0dda73a9f20ab0a7e03892b5ebffa5436b870613233fbd2024ca846 SHA512 20a254f1d6a4628a11f42c08947d1165430a020030da7e6ee7b22859b552245e8f3822a2d86c60055878ca00d8f17d346a0ad8274e8f0bb03ef4a9410b9630f1
+DIST libguestfs-1.44.1.tar.gz 23798268 BLAKE2B a2266d28e611204f03fc88c7a51331b49eb9fb908a318024bbc98af6a283ef4ba80be9caa0fb7e10f4d8bf67be5aaddae73d213828956e59f3233ab280a0185b SHA512 db6eab7350d9318a5ad5f968b24ed77ab411c9be3476b62b2b8448cf06db2462af1e3c9d8b02b54011d43651c281d74db7cb8023426a3f09667aa5b3597c7c33
diff --git a/app-emulation/libguestfs/files/1.44/0001-Check-for-caml_alloc_initialized_string-existence-ev.patch b/app-emulation/libguestfs/files/1.44/0001-Check-for-caml_alloc_initialized_string-existence-ev.patch
new file mode 100644
index 000000000000..a44743c9adc3
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.44/0001-Check-for-caml_alloc_initialized_string-existence-ev.patch
@@ -0,0 +1,25 @@
+https://sources.debian.org/data/main/libg/libguestfs/1:1.44.0-2/debian/patches/0016-Check-for-caml_alloc_initialized_string-existence-ev.patch
+
+From: Hilko Bengen <bengen@debian.org>
+Date: Tue, 10 Mar 2020 17:23:15 +0100
+Subject: Check for caml_alloc_initialized_string existence even if
+ --disable-ocaml
+
+---
+ m4/guestfs-ocaml.m4 | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/m4/guestfs-ocaml.m4 b/m4/guestfs-ocaml.m4
+index 18f95c2..bf07799 100644
+--- a/m4/guestfs-ocaml.m4
++++ b/m4/guestfs-ocaml.m4
+@@ -214,8 +214,7 @@ AM_CONDITIONAL([HAVE_BYTES_COMPAT_ML],
+ [test "x$have_Bytes_module" = "xno"])
+
+ dnl Check if OCaml has caml_alloc_initialized_string (added 2017).
+-AS_IF([test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno" && \
+- test "x$enable_ocaml" = "xyes"],[
++AS_IF([test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"],[
+ AC_MSG_CHECKING([for caml_alloc_initialized_string])
+ cat >conftest.c <<'EOF'
+ #include <caml/alloc.h>
diff --git a/app-emulation/libguestfs/libguestfs-1.44.1.ebuild b/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
new file mode 100644
index 000000000000..70a7fdc71653
--- /dev/null
+++ b/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit autotools bash-completion-r1 l10n linux-info lua-single perl-functions python-single-r1 xdg-utils flag-o-matic
+
+MY_PV_1="$(ver_cut 1-2)"
+MY_PV_2="$(ver_cut 2)"
+[[ $(( ${MY_PV_2} % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tools for accessing, inspect and modifying virtual machine (VM) disk images"
+HOMEPAGE="https://libguestfs.org/"
+SRC_URI="https://libguestfs.org/download/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/${MY_PV_1}"
+
+KEYWORDS="~amd64"
+IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua ocaml +perl python ruby selinux static-libs systemtap test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Failures - doc
+
+# FIXME: selinux support is automagic
+COMMON_DEPEND="
+ sys-libs/ncurses:0=
+ sys-devel/gettext
+ >=app-misc/hivex-1.3.1
+ dev-libs/libpcre:3
+ app-arch/cpio
+ dev-lang/perl:=
+ app-cdr/cdrtools
+ >=app-emulation/qemu-2.0[qemu_softmmu_targets_x86_64,systemtap?,selinux?,filecaps]
+ sys-apps/fakeroot
+ sys-apps/file
+ libvirt? ( app-emulation/libvirt )
+ dev-libs/libxml2:2=
+ >=sys-apps/fakechroot-2.8
+ >=app-admin/augeas-1.8.0
+ sys-fs/squashfs-tools:*
+ dev-libs/libconfig:=
+ sys-libs/readline:0=
+ >=sys-libs/db-4.6:*
+ app-arch/xz-utils
+ app-arch/lzma
+ app-crypt/gnupg
+ app-arch/unzip[natspec]
+ perl? (
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Sys-Virt-0.2.4
+ virtual/perl-Getopt-Long
+ virtual/perl-Data-Dumper
+ dev-perl/libintl-perl
+ >=app-misc/hivex-1.3.1[perl?]
+ dev-perl/String-ShellQuote
+ )
+ python? ( ${PYTHON_DEPS} )
+ fuse? ( sys-fs/fuse:= )
+ introspection? (
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/gobject-introspection-1.30.0:=
+ )
+ selinux? (
+ sys-libs/libselinux
+ sys-libs/libsemanage
+ )
+ systemtap? ( dev-util/systemtap )
+ ocaml? ( >=dev-lang/ocaml-4.03:=[ocamlopt] )
+ erlang? ( dev-lang/erlang )
+ inspect-icons? (
+ media-libs/netpbm
+ media-gfx/icoutils
+ )
+ virtual/acl
+ sys-libs/libcap
+ lua? ( ${LUA_DEPS} )
+ >=dev-libs/yajl-2.0.4
+ gtk? (
+ sys-apps/dbus
+ x11-libs/gtk+:3
+ )
+ net-libs/libtirpc:=
+ sys-libs/libxcrypt:=
+"
+# Some OCaml is always required
+# bug #729674
+DEPEND="${COMMON_DEPEND}
+ dev-util/gperf
+ >=dev-lang/ocaml-4.03:=[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ ocaml? (
+ dev-ml/ounit2[ocamlopt]
+ || (
+ <dev-ml/ocaml-gettext-0.4.2
+ dev-ml/ocaml-gettext-stub[ocamlopt]
+ )
+ )
+ doc? ( app-text/po4a )
+ ruby? ( dev-lang/ruby virtual/rubygems dev-ruby/rake )
+ test? ( introspection? ( dev-libs/gjs ) )
+"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-emulation/libguestfs-appliance
+"
+# Upstream build scripts compile and install Lua bindings for the ABI version
+# obtained by running 'lua' on the build host
+BDEPEND="lua? ( ${LUA_DEPS} )"
+
+DOCS=( AUTHORS BUGS ChangeLog HACKING README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${MY_PV_1}/
+)
+
+pkg_setup() {
+ CONFIG_CHECK="~KVM ~VIRTIO"
+ [[ -n "${CONFIG_CHECK}" ]] && check_extra_config
+
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ eautoreconf
+}
+
+src_configure() {
+ # Disable feature test for kvm for more reason
+ # i.e: not loaded module in __build__ time,
+ # build server not supported kvm, etc. ...
+ #
+ # In fact, this feature is virtio support and requires
+ # configured kernel.
+ export vmchannel_test=no
+
+ # bug #703118
+ append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/xcrypt"
+
+ econf \
+ $(use_with libvirt) \
+ --disable-appliance \
+ --disable-daemon \
+ --with-extra="-gentoo" \
+ --with-readline \
+ --disable-php \
+ $(use_enable python) \
+ --without-java \
+ $(use_enable perl) \
+ $(use_enable fuse) \
+ $(use_enable ocaml) \
+ $(use_enable ruby) \
+ --disable-haskell \
+ --disable-golang \
+ --disable-rust \
+ $(use_enable introspection gobject) \
+ $(use_enable introspection) \
+ $(use_enable erlang) \
+ $(use_enable static-libs static) \
+ $(use_enable systemtap probes) \
+ $(use_enable lua) \
+ $(usex doc '' PO4A=no)
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake DESTDIR="${D}" install "LINGUAS=""${LINGUAS}"""
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use perl ; then
+ perl_delete_localpod
+
+ # Workaround Build.PL for now
+ doman "${ED}"/usr/man/man3/Sys::Guestfs.3pm
+ rm -rf "${ED}"/usr/man || die
+ fi
+}
+
+pkg_postinst() {
+ if ! use gtk ; then
+ einfo "virt-p2v NOT installed"
+ fi
+
+ if ! use ocaml ; then
+ einfo "OCaml based tools and bindings (sysprep, ...) NOT installed"
+ fi
+
+ if ! use perl ; then
+ einfo "Perl based tools NOT built"
+ fi
+}