summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-13 15:22:33 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-13 15:22:33 +0100
commit1806d75a9a68a05e03545926891e2a5f2cf35de8 (patch)
treea09fc573983cfbebe17841d30d1117d51f0b478a /app-emulation
parentdev-db/etcd: Version bump to 3.3.1 (diff)
downloadgentoo-1806d75a9a68a05e03545926891e2a5f2cf35de8.tar.gz
gentoo-1806d75a9a68a05e03545926891e2a5f2cf35de8.tar.bz2
gentoo-1806d75a9a68a05e03545926891e2a5f2cf35de8.zip
app-emulation/runc: Remove old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/runc/Manifest1
-rw-r--r--app-emulation/runc/runc-1.0.0_rc2-r2.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/app-emulation/runc/Manifest b/app-emulation/runc/Manifest
index e61d2f4846a4..04d48733c733 100644
--- a/app-emulation/runc/Manifest
+++ b/app-emulation/runc/Manifest
@@ -1,2 +1 @@
-DIST runc-1.0.0_rc2.tar.gz 550449 BLAKE2B b2e8f122c8a469baddddb661b4c719f737be483966c3b374e2a86e556e84fe9d054ce2d5a7ff6b1be99970a22393426fdb21421a44532873b05fa29aa7503734 SHA512 83a3d45efbb86d3d583b96062202b9e60121d250af2c0dd37d07fda574b642aa6f05e29cac6644ad3d624647400db694082e280383e41ca9f31dc0a33b87ed76
DIST runc-1.0.0_rc4.tar.gz 1090513 BLAKE2B 276303e2085eddd549290e3af1a3af4570d0aef43f66f956267451810b0f0fb77f13ed12fe13b76efcd820fc7e0b46eac370a062f43c8600091a807cb12cf733 SHA512 cc2ae38b96f3f3355d9ba26f7af15c57975276aeaf58dcfe7fe5f0f0411ece8584a7cb51ae7fdd2f4109366f55ac8dfb86f225e26377fe07b685bbc56a2518ed
diff --git a/app-emulation/runc/runc-1.0.0_rc2-r2.ebuild b/app-emulation/runc/runc-1.0.0_rc2-r2.ebuild
deleted file mode 100644
index 0ecb0b79d1f7..000000000000
--- a/app-emulation/runc/runc-1.0.0_rc2-r2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/opencontainers/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="v${MY_PV}"
- RUNC_COMMIT="c91b5be" # Change this when you update the ebuild
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor hardened +seccomp"
-
-RDEPEND="
- apparmor? ( sys-libs/libapparmor )
- seccomp? ( sys-libs/libseccomp )
- !app-emulation/docker-runc
-"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-PATCHES=( "${FILESDIR}"/${P}-init-non-dumpable.patch )
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
-
- # Setup GOPATH so things build
- rm -rf .gopath
- mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
- ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
- export GOPATH="${PWD}/.gopath:${PWD}/vendor"
-
- # build up optional flags
- local options=(
- $(usex apparmor 'apparmor')
- $(usex seccomp 'seccomp')
- )
-
- emake BUILDTAGS="${options[*]}" \
- COMMIT="${RUNC_COMMIT}"
-}
-
-src_install() {
- dobin runc
-}