summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2018-02-01 23:24:05 +0000
committerMatthias Maier <tamiko@gentoo.org>2018-02-11 14:27:01 -0600
commit182471d585d63fe286d631949dc13abd6c209137 (patch)
treec3e1266534e11407cf5e3508839bacfa1abfc381 /app-emulation
parentapp-emulation/qemu: version bump to 2.11.0, important security fixes (diff)
downloadgentoo-182471d585d63fe286d631949dc13abd6c209137.tar.gz
gentoo-182471d585d63fe286d631949dc13abd6c209137.tar.bz2
gentoo-182471d585d63fe286d631949dc13abd6c209137.zip
app-emulation/qemu: Fix build with latest git:
* add hppa to softmmu targets * add aarch64_be to user targets * update the CFLAGS patch Signed-off-by: Matthias Maier <tamiko@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/7020
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/files/qemu-2.11.9999-cflags.patch24
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild6
2 files changed, 27 insertions, 3 deletions
diff --git a/app-emulation/qemu/files/qemu-2.11.9999-cflags.patch b/app-emulation/qemu/files/qemu-2.11.9999-cflags.patch
new file mode 100644
index 000000000000..8d7c387851a5
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-2.11.9999-cflags.patch
@@ -0,0 +1,24 @@
+--- a/configure 2018-02-01 22:51:53.068467555 +0000
++++ b/configure 2018-02-01 22:52:23.965041387 +0000
+@@ -5212,21 +5212,12 @@ fi
+ if test "$gcov" = "yes" ; then
+ CFLAGS="-fprofile-arcs -ftest-coverage -g $CFLAGS"
+ LDFLAGS="-fprofile-arcs -ftest-coverage $LDFLAGS"
+-elif test "$fortify_source" = "yes" ; then
+- CFLAGS="-O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 $CFLAGS"
+ elif test "$debug" = "yes"; then
+- if compile_prog "-Og" ""; then
+- CFLAGS="-Og $CFLAGS"
+- elif compile_prog "-O1" ""; then
+- CFLAGS="-O1 $CFLAGS"
+- fi
+ # Workaround GCC false-positive Wuninitialized bugs with Og or O1:
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=24639
+ if cc_has_warning_flag "-Wno-maybe-uninitialized"; then
+ CFLAGS="-Wno-maybe-uninitialized $CFLAGS"
+ fi
+-else
+- CFLAGS="-O2 $CFLAGS"
+ fi
+
+ ##########################################
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 97e3556cc400..51306b78bcb2 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -34,13 +34,13 @@ IUSE="accessibility +aio alsa bluetooth bzip2 +caps +curl debug +fdt
spice ssh static static-user systemtap tci test usb usbredir vde
+vhost-net virgl virtfs +vnc vte xattr xen xfs"
-COMMON_TARGETS="aarch64 alpha arm cris i386 m68k microblaze microblazeel
+COMMON_TARGETS="aarch64 alpha arm cris hppa i386 m68k microblaze microblazeel
mips mips64 mips64el mipsel nios2 or1k ppc ppc64 s390x sh4 sh4eb sparc
sparc64 x86_64"
IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS}
lm32 moxie ppcemb tricore unicore32 xtensa xtensaeb"
IUSE_USER_TARGETS="${COMMON_TARGETS}
- armeb hppa mipsn32 mipsn32el ppc64abi32 ppc64le sparc32plus tilegx"
+ aarch64_be armeb mipsn32 mipsn32el ppc64abi32 ppc64le sparc32plus tilegx"
use_softmmu_targets=$(printf ' qemu_softmmu_targets_%s' ${IUSE_SOFTMMU_TARGETS})
use_user_targets=$(printf ' qemu_user_targets_%s' ${IUSE_USER_TARGETS})
@@ -201,7 +201,7 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-qemu )"
PATCHES=(
- "${FILESDIR}"/${PN}-2.5.0-cflags.patch
+ "${FILESDIR}"/${PN}-2.11.9999-cflags.patch
"${FILESDIR}"/${PN}-2.5.0-sysmacros.patch
)