summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-28 07:58:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-28 08:13:36 -0400
commit19de57ffb76dd9aafb32d5086aa623bdb95c9efd (patch)
treed526ece0502c863444abb7662b2ebfc6cbeccfae /app-emulation
parentapp-emulation/wine-vanilla: warn if nvidia[abi_x86_32] is missing (diff)
downloadgentoo-19de57ffb76dd9aafb32d5086aa623bdb95c9efd.tar.gz
gentoo-19de57ffb76dd9aafb32d5086aa623bdb95c9efd.tar.bz2
gentoo-19de57ffb76dd9aafb32d5086aa623bdb95c9efd.zip
app-emulation/wine-staging: warn if nvidia[abi_x86_32] is missing
Hard to know for sure if it's really used or not, but do not want to introduce a kinda no-op VIDEO_CARDS on wine to actually depend on it over a warning. Less of an issue with mesa given other dependencies end up requiring it (technically the dep is wrong given e.g. nvidia would not need mesa[abi_x86_32], but well). (not needed with USE="wow64 -abi_x86_32" for 32bit) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-8.0.ebuild8
-rw-r--r--app-emulation/wine-staging/wine-staging-8.11-r1.ebuild8
-rw-r--r--app-emulation/wine-staging/wine-staging-8.12.ebuild8
-rw-r--r--app-emulation/wine-staging/wine-staging-8.13.ebuild6
-rw-r--r--app-emulation/wine-staging/wine-staging-8.14.ebuild6
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild6
6 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/wine-staging/wine-staging-8.0.ebuild b/app-emulation/wine-staging/wine-staging-8.0.ebuild
index 66827fdc086d..b28e3e16486b 100644
--- a/app-emulation/wine-staging/wine-staging-8.0.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.0.ebuild
@@ -381,6 +381,14 @@ src_install() {
}
pkg_postinst() {
+ if use abi_x86_32 && { use opengl || use vulkan; } &&
+ has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild b/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
index 67326eaf843f..55c76dfdc2da 100644
--- a/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
@@ -396,6 +396,14 @@ src_install() {
}
pkg_postinst() {
+ if use abi_x86_32 && { use opengl || use vulkan; } &&
+ has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-staging/wine-staging-8.12.ebuild b/app-emulation/wine-staging/wine-staging-8.12.ebuild
index 67326eaf843f..55c76dfdc2da 100644
--- a/app-emulation/wine-staging/wine-staging-8.12.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.12.ebuild
@@ -396,6 +396,14 @@ src_install() {
}
pkg_postinst() {
+ if use abi_x86_32 && { use opengl || use vulkan; } &&
+ has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-staging/wine-staging-8.13.ebuild b/app-emulation/wine-staging/wine-staging-8.13.ebuild
index d93f2f74f1f5..9f4dff71c714 100644
--- a/app-emulation/wine-staging/wine-staging-8.13.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.13.ebuild
@@ -442,6 +442,12 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
+ elif use abi_x86_32 && { use opengl || use vulkan; } &&
+ has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-staging/wine-staging-8.14.ebuild b/app-emulation/wine-staging/wine-staging-8.14.ebuild
index d93f2f74f1f5..9f4dff71c714 100644
--- a/app-emulation/wine-staging/wine-staging-8.14.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.14.ebuild
@@ -442,6 +442,12 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
+ elif use abi_x86_32 && { use opengl || use vulkan; } &&
+ has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index d93f2f74f1f5..9f4dff71c714 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -442,6 +442,12 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
+ elif use abi_x86_32 && { use opengl || use vulkan; } &&
+ has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
fi
eselect wine update --if-unset || die