summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-03-26 10:54:11 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-26 10:54:38 -0500
commit1bf94f912ec3ea1d85be913fe17482cd4649530b (patch)
tree9857478367360478249cc3b5df82e0b4496c8352 /app-emulation
parentprofiles: remove SuperH profiles (diff)
downloadgentoo-1bf94f912ec3ea1d85be913fe17482cd4649530b.tar.gz
gentoo-1bf94f912ec3ea1d85be913fe17482cd4649530b.tar.bz2
gentoo-1bf94f912ec3ea1d85be913fe17482cd4649530b.zip
app-emulation/buildah: 1.14.4 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.14.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index fd625149af0b..08a0935ed9cc 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -5,4 +5,5 @@ DIST buildah-1.13.1.tar.gz 10928426 BLAKE2B 7f790e2e6499543f6ddae5582f03e4e8a242
DIST buildah-1.14.0.tar.gz 10895764 BLAKE2B afc99c12737651997785ce96793afbff24e514a89e445ec5e176940940335b5966cf6e05e3d418d2aad2308d604e05879874eb5d5c07182dc0484e43411628e7 SHA512 c2fe27ccff81cc22dcb398f6d57f618015a1f534510888966483002d552c5f233b8899f639dac15d0f299c6c618e6f1d9889e65c745ce4709e7abd9498258a86
DIST buildah-1.14.2.tar.gz 11022035 BLAKE2B 8927d0d1c0ca75cc7fc739f990dbcb55a16ca34fee77a95fba629db6a5a73003ca320f85e6a9e4c4091e20877a7af00eee361c14b8b1758fe4bf690e179f6799 SHA512 d8f2488321cc52f1e2a390ffe975d83c4a6e9a169d47787715e0e04c29249abf501798bc3588d5d5c1bf70fc1a8451f75b102f629517da636cf9fd093667797c
DIST buildah-1.14.3.tar.gz 11039144 BLAKE2B 30ee37b083fd59084e19a4a02f3d2e86a6abc73293e1046a271a0d54629eff1aa858f914c21d67e1226ba42c1b19579c764551de45dab30a3d8f6dc173ec851d SHA512 89bc4256b0bea5b74ef71d0918f60d447fc4b0cd069f65995cf7125ed6382574c85db1c6a8101fbcb1c7385b5bc1855ddb1d483f91dce787ebab20ce56fad7e7
+DIST buildah-1.14.4.tar.gz 11020829 BLAKE2B a70e8dd567a5fea56735b18434bf630d278bb1aef7bc8b3ef4dc761c844fd2c1fa5839554586c6d908f67fdd2f755900cc9ac454f975edfcf62669456109d1bf SHA512 74923a552294b5e35361f8446697822850952edcd9b4619e31bad1c3b2fbb0aeb491d598096d2f59cf7bf433a487f056f7229c7fe031cb790cbdc9b8ba12a2cd
DIST containers-storage-1.14.0-vfs-user-xattrs.patch 14835 BLAKE2B 99c35933dcb25385ee83b80cf282c11c738d0e4d91216cc08a50522f6caa9bca5938299412908f16df404f99e80616a10b4c02c0ebc38240a987830ddaf15008 SHA512 62c7ed49728bd12b5706f59b0d4af3b18d90e8cfc2b06e681f84fe3f5d3e0cd5c0317147109c4e3ec4fec26f82c269af3c9813e47339ce102e4e97400b74627d
diff --git a/app-emulation/buildah/buildah-1.14.4.ebuild b/app-emulation/buildah/buildah-1.14.4.ebuild
new file mode 100644
index 000000000000..c06727f31789
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.14.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="selinux"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT=934ce1e9
+SRC_URI="https://github.com/containers/buildah/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}