summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2019-12-11 14:10:54 +0300
committerSergey Popov <pinkbyte@gentoo.org>2019-12-11 14:10:54 +0300
commit1e735027ae2223701efd202eb4d04b505aa1dcc2 (patch)
tree253aa92e1933ce74cf6bb5d9b493953b83c32324 /app-emulation
parentnet-p2p/rtorrent: amd64 stable wrt bug #702424 (diff)
downloadgentoo-1e735027ae2223701efd202eb4d04b505aa1dcc2.tar.gz
gentoo-1e735027ae2223701efd202eb4d04b505aa1dcc2.tar.bz2
gentoo-1e735027ae2223701efd202eb4d04b505aa1dcc2.zip
app-emulation/dynamips: version bump
Update metadata, bump EAPI Signed-off-by: Yury Martynov <email@linxon.ru> Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13306 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dynamips/Manifest1
-rw-r--r--app-emulation/dynamips/dynamips-0.2.21.ebuild40
-rw-r--r--app-emulation/dynamips/metadata.xml1
3 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
index 26e0ee3e5ed7..0a80e67861e2 100644
--- a/app-emulation/dynamips/Manifest
+++ b/app-emulation/dynamips/Manifest
@@ -1 +1,2 @@
DIST dynamips-0.2.18.tar.gz 833554 BLAKE2B 8152b436e8fc43061c5603a44ceae8feebdd4593649d2fb6a1814ca22cfce2f671f6f98df5f03ee6eeef10cf09fc444d406edd8d3b4a6037a89cf0e8301774ac SHA512 d66e32d72ecc9ebff5232377ac9aa5b966ceb08884cc7f8dc4a8cf3f56305e7cefd677624ba66278f6603a3b275c384bd0ff3905932461b1f8056106cd272a4c
+DIST dynamips-0.2.21.tar.gz 833863 BLAKE2B a3162de26839a4c99fd1f147fe0a12e04f4b225b6539aa1599550c40c6a9e21deed950b47f7afbbc1cfbe2f61a351a4185a18f56c4b63c191eccc7122e2c0115 SHA512 c7251963897b65ed5696f47f03be727cea79fe2245850c86fa6b4d8718afa10002b1e39bccefe1c7f2ba86fe6b8f52fe8663ee34f72ca3d9f846522b9b9b4d29
diff --git a/app-emulation/dynamips/dynamips-0.2.21.ebuild b/app-emulation/dynamips/dynamips-0.2.21.ebuild
new file mode 100644
index 000000000000..21b04e6456e7
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.21.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="https://github.com/GNS3/dynamips"
+SRC_URI="https://github.com/GNS3/dynamips/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ipv6"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README.md RELEASE-NOTES )
+
+PATCHES=( "${FILESDIR}/${PN}-0.2.18-docs.patch" )
+
+src_prepare() {
+ # comment out DYNAMIPS_FLAGS to respect CFLAGS
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DANY_COMPILER=1
+ -DENABLE_IPV6="$(usex ipv6)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-emulation/dynamips/metadata.xml b/app-emulation/dynamips/metadata.xml
index a7daaaa0bc6f..2f5d95978a96 100644
--- a/app-emulation/dynamips/metadata.xml
+++ b/app-emulation/dynamips/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="sourceforge">gns-3</remote-id>
+ <remote-id type="github">GNS3/dynamips</remote-id>
</upstream>
</pkgmetadata>