summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-03 15:22:46 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-03 15:22:46 +0100
commit277c2117108e246e5bfaa87093137f699dabf8f2 (patch)
tree4b3dc9f0a35b217ce7fb59d4a4ca333de3aa454a /app-emulation
parentsys-libs/libapparmor: remove 2.11.0-r1 (diff)
downloadgentoo-277c2117108e246e5bfaa87093137f699dabf8f2.tar.gz
gentoo-277c2117108e246e5bfaa87093137f699dabf8f2.tar.bz2
gentoo-277c2117108e246e5bfaa87093137f699dabf8f2.zip
app-emulation/containerd: Version bump to 1.0.0_beta2
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.0.0_beta2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index 88e8248cdb2d..13487eb536c4 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -2,3 +2,4 @@ DIST containerd-0.2.5_p20170308.tar.gz 1021631 SHA256 d08d3d0758b76f7de0e8f503b7
DIST containerd-0.2.9.tar.gz 1228977 SHA256 2360fec91d40e4e93757f964f07c74e35b6bfe838252b1cc814a176e1cd1c604 SHA512 6f0de476668e6b86a0cd5e1ea0f6dac24e0e68fe2dd52b8915dbafa5ffab137a5eea866c216f8184ffa6e4750c7b69bce3d46552e8be283a15ce676ea4356fc8 WHIRLPOOL b9fdd57af3cf39e6a5efdd67f0302ad38d6634d20aa3eb45431d2900f5fbb7dc62d624b07a5028bbb09ae763e07103e37703cf52f3e14e7af72fc2198d9c7876
DIST containerd-0.2.9_p20170605.tar.gz 1229549 SHA256 c506121c49e3bfea27018aa77e09e4734067f84ae85b6ef75ec31b488a91ae54 SHA512 900cf9c251c4de0f9848fb5bf26537226c1361d1a64a0fba853bda3805cb141fc2a849442fe885f0ee228b3e3a7018440af18898b484a54a7b75b4a86538aaa9 WHIRLPOOL 880f19a994f623b7cd8c3f771b5c56468681de349ae4196e60ffcb5a34d42ef423d8eefc82c07134c9e50c33bc0ecbfc1a9e47c3df987050d8dcb82da0178d80
DIST containerd-0.2.9_p20170917.tar.gz 1140788 SHA256 4d2b6e30bcc6c4bb901d6b9f19b5ac1d4a2d9b17075a9b1f110102920d01f64a SHA512 c749bda691197ec8a7603db9ad92f2800a3f065143430a660333b7862518deb4c158a1c1fd01671dff438b40988d4a64d8f06bab05496b8728c6e2f57cd7da0a WHIRLPOOL 75cb3467a94af50bef52377f309d7c85386475789fab3d2758679f022b516735728a1ac2c54307954a14100c4f84059d8fd5e8376270fdd69e572cff43453fa0
+DIST containerd-1.0.0_beta2.tar.gz 3681494 SHA256 3130384a814bc0a43fe3b76e2bbb2db2372fdc96490b76f8b278362ebc0d3fb1 SHA512 cecb4d2e0dccbc27c1e59f3e49f8fd5b08445988e49aa4b8a2a5910851509d51e001b5295905288c29fee2d91eadf2180a6b86947e130abe1b33a9a01416a286 WHIRLPOOL 4d526904a146971d57adbde6102e4fe42e0d303b102e721e34aaea3f54ef3176586dedf31a347f52d95a6e5c1850454b31ab3e5c6195b868929d32fde6218eb3
diff --git a/app-emulation/containerd/containerd-1.0.0_beta2.ebuild b/app-emulation/containerd/containerd-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..a9b3d5c5ae5a
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.0.0_beta2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_beta/-beta.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="a543c93"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND="sys-fs/btrfs-progs"
+RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
+ >=app-emulation/runc-1.0.0_rc4 )
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}