summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-03-17 10:00:49 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-17 10:01:14 -0500
commit4a4777fce5f9887dfe36457982cc36ad9263b80d (patch)
tree9b6d79058a4bedd87aa56af3f2f9548ecd26ce33 /app-emulation
parentapp-doc/geant-docs-4.10.6: fix filenames, bug 712984 (diff)
downloadgentoo-4a4777fce5f9887dfe36457982cc36ad9263b80d.tar.gz
gentoo-4a4777fce5f9887dfe36457982cc36ad9263b80d.tar.bz2
gentoo-4a4777fce5f9887dfe36457982cc36ad9263b80d.zip
app-emulation/cri-o: 1.17.1 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cri-o/Manifest1
-rw-r--r--app-emulation/cri-o/cri-o-1.17.1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-emulation/cri-o/Manifest b/app-emulation/cri-o/Manifest
index 09b553029755..ebf01ec2a21b 100644
--- a/app-emulation/cri-o/Manifest
+++ b/app-emulation/cri-o/Manifest
@@ -4,3 +4,4 @@ DIST cri-o-1.15.1.tar.gz 11811389 BLAKE2B 2f6e223e2d3964f480e9739ee4808101ae2ca8
DIST cri-o-1.15.2.tar.gz 11861335 BLAKE2B 159bdf322540c3d49f44b1fc1106d1717706f7817e4621743078dfbb5d9088318d7dda5da54ff94ed43ea58204413d496ffda424ea94ed6fd0c6e090bbba37f0 SHA512 d30a27d98537cd73bf341267922b94434958bf5e5d3a26de3af2b7899fd9d860be12a194531f81fb704abed79eac1c5139271fab1e52b994b939dafab00f1cfd
DIST cri-o-1.16.3.tar.gz 12274620 BLAKE2B e297996184e765a89cc68adbb531eb249ad74804b05d233b4730fe56cb530e2d6d7f44ecf6939730a055acff43b0bdec13fd40583fcf003740e6dacc9770d868 SHA512 cf3d8748696e14a9fe7bb1f4e4ed5532a84367e1de42da89e1c85c33f249525a42000c74445b1f6859099a43d4076c4078efe5990a7e663795121d54d1ee1354
DIST cri-o-1.17.0.tar.gz 10528650 BLAKE2B ba1240e602be576eb74bd9dd0c7b5d0ae3c78172902c74725ce3b85b90c739a79cf260b9ab441bc632eba85951ff1968a946824dd20849bb9ccae268b76e3fec SHA512 08b1ede35d44dd72f7a20ef02e3d27198d349d05b3fd41fc319bfba44dafdaf1843c1a6b04cd4d07ad80b5d2022376a8173b7459658a3c22011970561a1af308
+DIST cri-o-1.17.1.tar.gz 10532728 BLAKE2B 12747b0161ca2fa7dc7e95fd4c000b9011402e65dac0885ed59a37a87b53907044d3b3c873d6fe82186313af6745e463ce84be259dae99793c6363794c76e16f SHA512 1548c4b20081e8f1af772b0b0fadd0f1b63af641283bef8b8cd8478bd626699c23b30b39fe460660776bc7e6509e85db73d1d7e0d030dd7bd3dbfe319c82e332
diff --git a/app-emulation/cri-o/cri-o-1.17.1.ebuild b/app-emulation/cri-o/cri-o-1.17.1.ebuild
new file mode 100644
index 000000000000..f8d6d2c59f40
--- /dev/null
+++ b/app-emulation/cri-o/cri-o-1.17.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT=ee2de87bd8e2a7a84799476cb4fc4ce8a78fdf6d
+
+inherit go-module
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-emulation/conmon
+ app-emulation/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ net-misc/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ sys-libs/libseccomp:=
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ selinux? ( sys-libs/libselinux:= )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ !<app-emulation/libpod-1.3.2-r1"
+
+src_prepare() {
+ default
+
+ sed -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ GOBIN="${S}/bin" \
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install install.config install.systemd
+
+ keepdir /etc/crio
+ mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conf
+}