summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-04-29 10:22:59 -0700
committerZac Medico <zmedico@gentoo.org>2019-04-29 10:23:21 -0700
commit60b00d3a736212b41d6482784b8900bc7e43c6a0 (patch)
tree0afd1a07bd8826767a9e86cd1d2ee70237c80539 /app-emulation
parentdev-libs/librdkafka: remove automagic on app-arch/zstd (diff)
downloadgentoo-60b00d3a736212b41d6482784b8900bc7e43c6a0.tar.gz
gentoo-60b00d3a736212b41d6482784b8900bc7e43c6a0.tar.bz2
gentoo-60b00d3a736212b41d6482784b8900bc7e43c6a0.zip
app-emulation/cri-o: remove old version 1.13.0
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cri-o/Manifest1
-rw-r--r--app-emulation/cri-o/cri-o-1.13.0.ebuild105
2 files changed, 0 insertions, 106 deletions
diff --git a/app-emulation/cri-o/Manifest b/app-emulation/cri-o/Manifest
index b372cadcda18..cb7d987023a3 100644
--- a/app-emulation/cri-o/Manifest
+++ b/app-emulation/cri-o/Manifest
@@ -1,3 +1,2 @@
DIST cri-o-1.10.6.tar.gz 5161858 BLAKE2B bbfaf60c92dee3a9f42e9d4fc9b5482057a7a0ff2de36d74d434e2e60b53f92f70980c83825c18089c4a48bfa01c164b77aa01506c68c763f00265796e07d367 SHA512 b6a412cf5859dab79095732c2528e2ba373b3c21740203441fd3646862e2458e78e71f1895a5def05207964ef96a354c04395356e426600994bb39d3adfd0894
-DIST cri-o-1.13.0.tar.gz 6499846 BLAKE2B 71edb779a4e126ca8a1959c51a86d3f223f66ecbd492a0c314de0f7b5ed0c39b5f0c0550e5690a388ebc00d6f2f5a2dc675e8bf67ed6805b0e5e0cd000e9211a SHA512 52b764bda68d0f9f9467a5db92b5d955aa220f9570cfc2393854ca884b473cb2ef1cb0fc5ab3da9350a162e486440ad6109de9d9214b6b2fbe5bb82cb37c1283
DIST cri-o-1.13.5.tar.gz 6683259 BLAKE2B 982de5590411ad618401a2909dcd4f0404d5bfc49667027e29fd266e3e2d15bbf0d7716db570d433eec7f2baacbb33f7e9e0f347aa2ef964a06b8b883f76404c SHA512 116e51e9b31fca66b4edd9aac5d1f0c8929ba9a740af8b611fb7fa0e675e37facd4114d0848090b32f72f58d17c85060c15e07bee82098d83a0bd5b563f4c875
diff --git a/app-emulation/cri-o/cri-o-1.13.0.ebuild b/app-emulation/cri-o/cri-o-1.13.0.ebuild
deleted file mode 100644
index 6b934dd9e8e4..000000000000
--- a/app-emulation/cri-o/cri-o-1.13.0.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_COMMIT="e8a2525c2e7f5ab057d5a2b5f1950be5643d8053"
-EGO_PN="github.com/kubernetes-sigs/${PN}"
-
-inherit golang-vcs-snapshot systemd
-
-DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
-HOMEPAGE="https://cri-o.io/"
-SRC_URI="https://github.com/kubernetes-sigs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="btrfs +device-mapper ostree seccomp selinux"
-
-COMMON_DEPEND="
- app-crypt/gpgme:=
- app-emulation/runc
- dev-libs/glib:=
- dev-libs/libassuan:=
- dev-libs/libgpg-error:=
- net-firewall/conntrack-tools
- net-firewall/iptables
- net-misc/cni-plugins
- net-misc/socat
- sys-apps/iproute2
- btrfs? ( sys-fs/btrfs-progs )
- device-mapper? ( sys-fs/lvm2:= )
- ostree? ( dev-util/ostree )
- seccomp? ( sys-libs/libseccomp:= )
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="
- ${COMMON_DEPEND}
- dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
- default
-
- sed -e '/^GIT_.*/d' \
- -e 's/$(GO) build/$(GO) build -v -work -x/' \
- -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
- -i Makefile || die
-
- sed -e 's:/usr/local/bin:/usr/bin:' \
- -i contrib/systemd/* || die
-}
-
-src_compile() {
- [[ -f hack/btrfs_installed_tag.sh ]] || die
- use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
- hack/btrfs_installed_tag.sh || die; }
-
- [[ -f hack/libdm_installed.sh ]] || die
- use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
- hack/libdm_installed.sh || die; }
-
- [[ -f hack/ostree_tag.sh ]] || die
- use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
- hack/ostree_tag.sh || die; }
-
- [[ -f hack/seccomp_tag.sh ]] || die
- use seccomp || { echo -e "#!/bin/sh\ntrue" > \
- hack/seccomp_tag.sh || die; }
-
- [[ -f hack/selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- hack/selinux_tag.sh || die; }
-
- mkdir -p bin || die
- GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
- emake binaries docs
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install.bin install.man
-
- keepdir /etc/crio
- insinto /etc/crio
- use seccomp && doins seccomp.json
-
- "${ED}"/usr/bin/crio --config="" config --default > "${T}"/crio.conf.example || die
- doins "${T}/crio.conf.example"
-
- newinitd "${FILESDIR}/crio.initd" crio
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
-
- # Suppress crio log error messages triggered if these don't exist.
- keepdir /etc/containers/oci/hooks.d
- keepdir /usr/share/containers/oci/hooks.d
-
- # Suppress crio "Missing CNI default network" log message.
- keepdir /etc/cni/net.d
- insinto /etc/cni/net.d
- doins contrib/cni/99-loopback.conf
-
- systemd_dounit contrib/systemd/*
-}