summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-10-07 11:22:59 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-10-07 11:22:59 +0200
commit6b4037d00d463a16a1a0aaa4c70364bf2fd2103c (patch)
tree5093ae5a402f9b16655e7b628993a482b112e6b5 /app-emulation
parentnet-libs/nodejs: [QA] Drop old, broken ebuilds (diff)
downloadgentoo-6b4037d00d463a16a1a0aaa4c70364bf2fd2103c.tar.gz
gentoo-6b4037d00d463a16a1a0aaa4c70364bf2fd2103c.tar.bz2
gentoo-6b4037d00d463a16a1a0aaa4c70364bf2fd2103c.zip
app-emulation/runc: Version bump to 1.0.0_rc9
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/runc/Manifest1
-rw-r--r--app-emulation/runc/runc-1.0.0_rc9.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/runc/Manifest b/app-emulation/runc/Manifest
index c96feb04e9c2..bf55e8a0f792 100644
--- a/app-emulation/runc/Manifest
+++ b/app-emulation/runc/Manifest
@@ -1 +1,2 @@
DIST runc-1.0.0_rc8.tar.gz 1665924 BLAKE2B 542cbdefaaa1ef89d2abf8e31ca8116f26cddbfc3fb94dc8c7e94c51750b179ed557bee857ec80ede7280856c66c01c7961a26dc7e6202276baca46c691a3903 SHA512 f213b6a7fa96597d2ba1068f77752bccc0a1d62e0aac02ec8d2a2552dc3c1140fd4e52b2daeb0ac8fc09c48abe4521834450baae01ad4165308813eee7654a2b
+DIST runc-1.0.0_rc9.tar.gz 1885161 BLAKE2B 638f00b857f43204cdc2b4e65927d6280e48b075d8363570e9da166ec35febaa749c733478d5c190c0119e0d95418e3295adcc129b68afbc5fec20ca3d9e9b59 SHA512 56c46fbe4d637a83d67e0aabf2549ba687d8b1e357fdecfffca343c8b166edf4158830aa0a4419edd6994c589b874bb8504eb3969ed3430cda6e233940d34194
diff --git a/app-emulation/runc/runc-1.0.0_rc9.ebuild b/app-emulation/runc/runc-1.0.0_rc9.ebuild
new file mode 100644
index 000000000000..add890e1a322
--- /dev/null
+++ b/app-emulation/runc/runc-1.0.0_rc9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/opencontainers/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-build golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ RUNC_COMMIT="d736ef14f0288d6993a1845745d6756cfc9ddd5a" # Change this when you update the ebuild
+ SRC_URI="https://${EGO_PN}/archive/${RUNC_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-build golang-vcs-snapshot
+fi
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+ambient apparmor hardened +kmem +seccomp"
+
+RDEPEND="
+ apparmor? ( sys-libs/libapparmor )
+ seccomp? ( sys-libs/libseccomp )
+ !app-emulation/docker-runc
+"
+
+src_prepare() {
+ pushd src/${EGO_PN}
+ default
+ sed -i -e "/^GIT_BRANCH/d"\
+ -e "/^GIT_BRANCH_CLEAN/d"\
+ -e "/^COMMIT_NO/d"\
+ -e "s/COMMIT :=.*/COMMIT := ${RUNC_COMMIT}/"\
+ Makefile || die
+ popd || die
+}
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
+
+ # build up optional flags
+ local options=(
+ $(usex ambient 'ambient' '')
+ $(usex apparmor 'apparmor' '')
+ $(usex seccomp 'seccomp' '')
+ $(usex kmem '' 'nokmem')
+ )
+
+ GOPATH="${S}" emake BUILDTAGS="${options[*]}" -C src/${EGO_PN}
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin runc
+ dodoc README.md PRINCIPLES.md
+ popd || die
+}